MP 1,1-5,1 Samsung M.2 970 EVO Plus firmware upgrade problem solved

MIKX

macrumors 65832
Original poster
Dec 16, 2004
1,503
540
Aussie in Japan
EDIT : If you buy a Samsung 970 EVO M.2 blade, install it but before formatting check the FIRMWARE revision in " About this Mac/ NVMe "first.
It should be 2B2QEXM7.
If it is 1B2QEXM7 you will have problems with the blade.

====================================================

I bought a 500gb Samsung 970 EVO on Saturday. I realised that the firmware had to be checked as the 970 EVO's firmware in the first release from Samsung ( 1B2QEXM7 ) was causing kernel panics etc.

Sure enough looking in " About this mac / Hardware / NVME the firmware was the problomatic" 1B2QEXM7 ".

So, I fired up Win 7 and ran Samsung Magician . .but .. . I got a popup message saying that it needed Microsoft .NET v 4.6.
this had never happened before. So I ran Win 8.1 and got the same message.

Microsoft ,Net message.PNG


Now I was starting to get worried. so I did two re-installations of Win 7 in both 32bit & 64 bit.

Got the same popup when I tried to run Samsung Magician.

After quite a while and many net searches I happened on the solution over at tonymacx86's haxckintosh forums.

Post #137
.

I then .. .

1. Downloaded "UNetbootin " https://unetbootin.github.io/

2. The latest Samsung 970 EVO Plus firmware ISO
https://www.samsung.com/semiconductor/minisite/ssd/download/tools/
scroll down to FIRMWARE then to “Samsung SSD Firmware(24).

Downloaded the " Samsung_SSD_970_EVO_2B2QEXE7.iso ".
( The latest firmware for the 970 EVO Plus is 2B2QEXM7 )

3. Inserted a brand new 8gb USB stick ( note : Don't change the original format the format of the USB stick.)

4. Started up UNetbootin by using the mouse RIGHT BUTTON & selecting OPEN. Just clicking the app won't open it.
Pointed the App to the ISO & the USB stick
Hit "OK" .. then UNetbootin formatted the USB stick bootable.

5. NOTE : At this point an EFI flashed GPU is required- I shutdown & installed my flashed XFX HD 5770.

6. Booted up holding down the OPTION key for the pre-boot selection screen ..

. . there it was ! My USB stick shown as " efi boot.

UNetBootin ready to boot.JPG


7. Started the "Efi Boot and then UNetbootin started up.

UNetBootin running.JPG


The rest was simple & easy. In about 10 seconds it found my 970 EVO Plus and asked me if I wanted to update it.
I typed in "Y".

Another 20 seconds and it was done.

I now have the latest ( 2B2QEXM7 ) firmware on my 970 EVO Plus.

DONE.png



I have since cloned Mojave 10.14.6 ( build 18G2020 ) over to the 970 EVO Plus formatted in HFS+.

Everything is running perfectly, no issues at all.

========================================

I also have a 970 EVO installed and I have noticed that the 500gb 970 EVO Plus is definitely faster and doesn't slow down as much as caches fill up.
DiskSpeedTest 970 EVO Plus.png


Of course not everyone has an EFI flashed GPU ( I have three ! ) and of course Samsung Magician probably works properly for other people but it is comforting for me to know that I could successfully upgrade my 970 EVO Plus via Mac OS .. sort of.

Hope this post is useful to anyone experiencing problems with Samsung Magician.

 

Rossthephotographer

macrumors member
Sep 21, 2017
38
1
UK
I'm having a real nightmare with my 2TB 970 Evo Plus NVMe.

I have a 2009 4,1 upgraded to 5,1 and have Mojave running on a 2.5" SSD on a Sonnet PCIe card. I'm trying to clone the OS to the new NVMe, but the process keeps crashing the computer.

Originally I formatted the NVMe as Mac OS journaled, but now after some failures to clone to it, it only gives me the APFS options.

I've done a bit of reading and I can see that:
• My Boot ROM version is: 144.0.0.0.0
• Mojave is build 18G3020
• The NVMe revision is 2B2QEXM7

So it would appear I have all the right specs, but it just fails to clone.

In my PCIe slots
• Top slot (slot 4?): An eSATA card as I have a HDD caddy to quickly insert drives like Time Machine.
• Slot 3: Sonnet Tempo Card with two 1TB Samsung 2.5" SSDs on it
• Slot 2: I/O CREST SI-PEX40129
• Slot 1: Sapphire Pulse Radeon RX 580 8G GDDR5

I really need to use all these slots and it is my work computer.

This NVMe problem is holding up my photography work and I am at my wits end after jumping through numerous hoops yesterday trying to upgrade from El Capitan and all sorts of obstacles presenting themselves to me. I'm hoping this is the final hurdle, but I don't know how to solve this issue.

I would be so appreciative if someone were able to help me figure this problem out. I really need to use the computer for work in the next 24hrs so this is pretty urgent to me.
 

MIKX

macrumors 65832
Original poster
Dec 16, 2004
1,503
540
Aussie in Japan
I live in a city in mid-Japan. Bought it here from a popular PC supply shop, the box was sealed and was sold as new. This week I told one of the senior staff ( in Japanese * ** ** * ) about the old firmware which was also problematic with WIN PCs too . . he just shrugged.
 

H. Flower

macrumors 6502a
Jul 23, 2008
529
432
Yikes, one of my four blades in my RAID0 is 1B2QEXM7.

Any idea how to upgrade the firmware if I don't have windows installed?
 

MIKX

macrumors 65832
Original poster
Dec 16, 2004
1,503
540
Aussie in Japan
Yikes, one of my four blades in my RAID0 is 1B2QEXM7.

Any idea how to upgrade the firmware if I don't have windows installed?
H.Flower

You will have to format it to MS.DOS FAT in High Sierra or Mojave 's Disk utility first then you ( MAYBE ) can do the firmware upgrade via Mac OS . . . . .


I did the firmware upgrade via Mojave & a USB thumb drive but I DO have Windows 10 on a separate spinner HDD so I could easily format it to NTFS.

( NOTE :I suppose that you could download ( not sure ) a 30 day trial of Win 7 / Win 10 & install it to a spare SSD/HDD ) - can anyone verify this ?)

If you have the Paragon software ( Google " Paragon NTFS Mac OS" ) that will allow you to format the blade to NTFS then the technique in the link above should work. No guarantees though - read the link instructions carefully.




=======================================================

You could also install your PCIe M.2 adapter card with the blade formatted to MS DOS FAT in mac OS - in a friend's Win PC then a popup will allow you to format the blade to NTFS. Then you can use Samsung Magician to upgrade the firmware to 2B2QEXM7.

Whatever, that 1B2QEXM7 firmware is definitely problematic in both PCs & CMPs.

====================

I always check the firmware of newly purchased Samsung blades in "About this Mac / System Report NVME Express/ "
prior to formatting in Mac OS.
 

Earl Urley

macrumors 6502
Nov 10, 2014
420
162
One thing to remember about buying SSDs sight unseen, even if a box is seemingly 'sealed' all it takes for an enterprising person to convert a used part into a seemingly new in box part is to warm up their shrinkwrap / heat seal machine and make sure the original packaging has been carefully handled so as not to put wrinkles or creases in it that suggest it had been opened.

Generally the best way to tell if something is truly new is to check to see that the part has one of those hologrammed / embossed stickers over the opening slits for the packaging. If it's missing or seems altered then it's probably not NIB.