Samsung printer drivers for ML-1740 for OS X 10.9 (Mavericks)

Discussion in 'OS X Mavericks (10.9)' started by skinerd, Nov 13, 2013.

  1. skinerd macrumors newbie

    Joined:
    Nov 13, 2013
    #1
    Is there a working driver for the samsung ML-1740 printer yet? Before I upgraded my Macbook Pro to 10.9, I used a driver called "Splix" to use my ML-1740 printer with. But after upgrading to 10.9, and I go and select the splix driver under the printer name ML-1740, it will not let me add to the list of drivers associated with the ML-1740.

    If someone out there knows anything about which driver can work with a ML-1740 printer, please help me.

    I did use the live support on the samsung website, and they say there are no supporting drivers yet for this model of printer.

    If there really are no drivers available yet for this printer, am I still able to use the same printer via printer sharing with another windows computer?
     
  2. weckart macrumors 68040

    Joined:
    Nov 7, 2004
    #2
    Try this:

    Download 1.1 Spllix (might work with 2.0). Drill into the packages via Show Contents until you find the correct ppd file for your printer. Copy that to your desktop or wherever. Go into the printer setup and when it asks for a driver select 'Other' and navigate to your ppd file. Worked for me.
     
  3. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #3
    Apple heard your cries and released Apple-Samsung Printer Drivers. So check your Software Update with the Samsung printer or manually download it.
     
  4. skinerd thread starter macrumors newbie

    Joined:
    Nov 13, 2013
    #4
    [​IMG]

    I have already tried installing spllix 1.1 / 2.0 driver and the samsung driver update for apple, but when I go into the "select driver" tab, the ML-1740 is not listed. Are you sure it works with this model of printer?

    Also, if I just want to share the printer with another windows computer, do I need a driver for that as well? Or can I just share it via the home network?
     
  5. skinerd thread starter macrumors newbie

    Joined:
    Nov 13, 2013
    #5
    So I'm still not able to find a suitable printer driver for this printer version, Samsung ML-1740. Spllix versions of the driver does not work with Mavericks OSX apparently, or if it does, I can't seem to get it to work properly. I'm wondering if anyone knows of a solution to this? Thanks.
     
  6. pastrychef macrumors 601

    pastrychef

    Joined:
    Sep 15, 2006
    Location:
    New York City, NY
    #6
    Is it possible to try and use the ML-1640 or ML-2240 drivers? Since those printers and your ML-1740 use the SPL printer language, there's a chance it may work...
     
  7. maylene macrumors newbie

    Joined:
    Jan 27, 2014
    #7
    Thanks for the Hints

    Finally compelled to create an account today to offer what worked for me, Mavericks, and my old reliable ML-1740. Thanks to everyone's input so far which pointed me in the right direction.

    Splix 2.0 found here works fine. I first deleted my (non-working) ML-1740 printer in System Preferences and then installed Splix. When re-adding the printer, the system detects the driver and displays a message about adding a 'Generic' printer/driver (sorry, no screenshot). Go with it.

    After banging my head on the previously-mentioned Samsung/Apple v2.6 driver for an hour, changing direction and using Splix took <5 minutes. Thanks again!
     
  8. ladyco macrumors newbie

    Joined:
    Apr 13, 2014
    #8
    Thanks

    I just want to thank Maylene for her final post. I just today updated to Mavericks and found my Samsung 1740 not working. Your clear concise instructions regarding this fix made it a pain free update to Splix 2.0 Wanted to make sure you knew that by taking the time to document your fix, it has helped another.
     
  9. BrianColgate macrumors newbie

    Joined:
    Feb 9, 2013
    #9
    My thanks, too, Maylene

    [COLOR="#03366"]I am running an iMac 27 with OS X 10.9.3 [Mavericks]

    I ran SpliX V. 2.0.0 after the Gutenprint driver did not work. At first SpliX would not work either. When I tried to print it powered up the printer, but did not actually print. After reading your post I deleted the ML-1740 again and reinstalled it, selecting SpliX -- the 'Generic' printer/driver you mentioned was not offered to me.

    I tried printing again and there was a warning message below the filename in the print status box: "Printing - SpliX Cannot get input slot information" ... however, it printed this time.

    If I had not seen your posting, I may well have given up. I have another laser printer - I originally bought the ML-1740 to use at work and I'm retired now. I simply wanted to know that the ML-1740 would work on both a PC and a Mac so I could offer it on Freecycle with a clear conscience and the ability to talk the new owner through setup on either computer.[/COLOR]
     
  10. msingham macrumors newbie

    Joined:
    Jul 23, 2014
    #10
    Thanks Maylene!

    Your suggestion worked like a charm!
     
  11. JustinF macrumors newbie

    Joined:
    Oct 14, 2014
    #11
    ML-1740, Mavericks and Splix 2.0.0 not working

    Hi All
    I have an ML-1740 & have just upgraded to 10.9.5 (Mavericks). Splix used to work but now doesn't. I've read the posts above (thanks), and I have re-installed SpliX 2.0.0, but I do not see any 'Generic' driver when re-installing the printer - all I see is the same old 'Samsung ML-1740, SpliX, V 2.0.0' - which looks like it's going to work, but doesn't

    Any ideas?

    cheers
     

    Attached Files:

  12. dcnblues macrumors member

    Joined:
    Oct 23, 2007
    #12
    SpliX Cannot get input slot information

    IF anyone is having this issue, where you get this notification "SpliX Cannot get input slot information," I found the following fix and am SO grateful for it. Samsung ML-1710 on Mavericks.

    Brad's fix (http://guigo.us/mac/splix/) worked for me, thank you jesus! FYI, his directions SEEM to suggest using a VI editor to modify the 'rasteroqpdl' file. They aren't (can't tell you how much time I wasted figuring that out).

    They're actually just an input of a fairly simple unix command. Here's how for non-techies as I really really appreciated getting my laser printer to function again:

    First, Reset Printing System (in Mac OS X v10.5.x or 10.6.x, and later):

    Choose System Preferences from the Apple menu.
    Choose Printers & Scanners from the View menu.
    Hold down the Option key while clicking the "-" (Remove printer) button. If no printers are currently added, hold down the Control key while clicking in the box that appears above the "+" (Add printer) button, then choose Reset printing system… from the contextual menu.
    Then reload your printer by using the Add + box.

    You’ll then need to reveal hidden files, and after opening a terminal window (Applications, Utilities [Other], Terminal), you'll need to type in a command as a superuser. This is dangerous and a little scary, but not if you follow directions EXACTLY.

    Click inside the terminal window and hit return once or twice to verify you're on the cursor there. Once you verify you are, type in this line (easiest to cut and paste what's inside the quotes): "defaults write com.apple.finder AppleShowAllFiles -bool TRUE" then hit return.
    The type: "killall Finder" and hit return.

    Click outside of the Terminal window. Then open a new finder window, go to ‘list’ or ‘cover flow’ view (2nd or 4th little boxes in a group of 4 in top of finder window) and when you do, you'll see greyed out files which were previously hidden. (If you don’t, try Alt/Finder in the dock, then select ‘Relaunch’). In the finder, navigate from your home machine to the the folder Brad lists (/usr/libexec/cups/filter/), and if you see ‘rastertoqpdl’ you can proceed. Try to drag the ‘filter’ folder right into the terminal window. You should see, in the command line, a new location. Click inside the terminal window, hit return to confirm you’re there, and type ‘ls -a’ and hit return. You should see the same list of files that you see in the finder window.

    Paste this line “SUDO ln -s gstoraster pstoraster” and hit return. Type in your admin password.
    Paste this line “defaults write com.apple.finder AppleShowAllFiles -bool FALSE” and hit return.
    Paste this line “killall Finder” and hit return.
    type in ‘exit’ and use the cursor to quit Terminal. Open a new finder window, and try to print. It should work. Thanks very much Brad. You’re a lifesaver.
     
  13. truelies macrumors regular

    Joined:
    Oct 14, 2011
    #13
    I followed this instruction and tried to print a shipping label. It still has "SpliX Cannot get input slot information," the bar code can't be printed.


     
  14. jolleyjoe macrumors newbie

    Joined:
    Jul 17, 2009

Share This Page