Samsung SSD Problems in Macbook 5,3

Discussion in 'MacBook Pro' started by Pete4 1.8t, Feb 6, 2012.

  1. Pete4 1.8t macrumors newbie

    Joined:
    Feb 6, 2012
    #1
    Hey Everyone (first post here!),

    Sooo I picked up a Samsung 830 Series SSD (256 gig) for my 15inch Macbook Pro 5,3. When I first got it I cloned my existing HD and put it in and it seemed to work brilliantly. Then I noticed the occasional spinning beach ball of death and occasional kernel panics. I updated the firmware on the drive and optimized with with the drive magician and it was still being flakey! I ended up wiping the entire drive and doing a clean install of Lion to see if that would improve it. Once again it worked fine until it started locking up and freezing on everything. Last night it had a complete meltdown and repeatedly kernel panicked no matter what I seemed to do (I was only trying to watch a video!) It came to the point where I could barely get it to boot and last long enough to copy a few files off of it. So I ended up having to wipe the drive again and the first attempt of installing OSX failed and I went back and zero'ed out all of the data and got Snow Leopard to successfully install. Now I'm up and running but hesitant to do much because I can't seem to figure out what the problem is.

    I'm thinking either the SSD is defective or the SATA cable from the motherboard is bad? Currently it seems to be running fine and boots extremely fast but if I run a speed test (screenshot attached) it doesn't seem to perform like it should. I have searched the forum and read the threads about this SSD and it looks like a few people have had problems but I can't seem to find a solution that I haven't already tried.

    The MacBook in question is 2.8 ghz, 4gig of RAM, etc. The only thing that has been changed is the new SSD.

    Any help would be appreciated, sorry I seem to write the longest posts in the world...

    [​IMG]
     
  2. aldejesus macrumors regular

    Joined:
    Feb 3, 2011
    Location:
    PR
    #2
    If I'm not wrong you have a mid 2009 MBP. Those only have Sata 2 connetion. Thats why you dont see the advertised speeds. This is what I got on my Early 2011 MBP with a Sata 3 connection. Disk Speed Test 2.1.
     

    Attached Files:

  3. thefizzle657 macrumors regular

    Joined:
    Oct 21, 2011
    #3
    You MBP is a 2009 model, right? I might be wrong but I think that your MBP is from the ones that suffer the issue with the SATA connection when updating to EFI 1.7 which supposedly updated the chipset's SATA speed from SATA I to SATA II but caused lots of problems for people.

    See http://forums.macrumors.com/showthread.php?t=729883&page=27

    If that is the MBP that you have, the only solution seems to be to downgrade to EFI version 1.6. You would be limited to SATA I speeds but that would be a lot better than constant lock-ups and kernel panics.
     
  4. Pete4 1.8t thread starter macrumors newbie

    Joined:
    Feb 6, 2012
    #4

    Thanks for this! I followed the instructions and downgraded to EFI 1.6. During normal use computer still seems very fast but now much more stable. I haven't done much on it yet and am still running Snow Leopard for now. I called Samsung and they offered to send me a replacement. I'm going to try it out for a few days before I get a new one. I'll definitely take it to school and work tomorrow though and see if I can get it to lock up/crash again.
     

Share This Page