Samung 840 Evo - How To Upgrade Firmware?

Discussion in 'MacBook Pro' started by A4orce84, Feb 2, 2014.

  1. A4orce84, Feb 2, 2014
    Last edited: Feb 2, 2014

    A4orce84 macrumors 6502

    Joined:
    Apr 17, 2012
    #1
    Hey Guys,

    I recently purchased a Samsung 840 Evo and installed it into my 2009 Macbook Pro. I recently got everything up and running, and it's awesome, but had 2 additional questions:

    Questions:
    1. How can I tell what version of the firmware I'm running in OSX Mavericks? I tried googling, but I didn't find much on how to tell what version I'm running.

    2. How do you update the firmware? I saw on Samsung's website they have .iso files for Mac.....but I currently don't have a optical drive in my macbook. Can I update via USB?

    I found the following post, but it didn't talk about USB option for upgrading firmware:
    http://forums.macrumors.com/showthread.php?t=1682996



    Thanks,
    Asif
     
  2. Jaben3421 macrumors regular

    Joined:
    Sep 18, 2011
    Location:
    CA
    #2
    To find out what firmware you're on, go to the apple logo in the left corner ->About This Mac->More Info->System Report->SATA/SATA Express and look for the "Revision" and that's your firmware version. As for the USB stick question, I have tried it to no avail. I eventually had to burn the .iso to a disc, but that was a 840 Pro's firmware. It may work with the Evo, but I don't own one and don't know.
     
  3. A4orce84 thread starter macrumors 6502

    Joined:
    Apr 17, 2012
    #3
  4. A4orce84 thread starter macrumors 6502

    Joined:
    Apr 17, 2012
  5. whitedragon101 macrumors 6502a

    Joined:
    Sep 11, 2008
    #5
    Do you run bootcamp ?
     
  6. imorton macrumors 6502

    Joined:
    Aug 21, 2010
    #6
    I'm following this thread also, and I'm curious if I can boot my Macbook Pro from an externally connected USB CD Drive? using this upgrade SSD Firmware.

    As another option, can we create a bootable SD memory card, and boot from that?

    My 250Gig 840 Evo that I purchased in Dec 2013 has EXT0BB0Q firmware, so I don't know what the newer EXT0BB6Q does?

    Thanks for any tips. :)
     
  7. Marty62 macrumors 6502

    Joined:
    Mar 11, 2010
    Location:
    Berlin formerly London
    #7
    I am also on Rev EXT0BB0Q since November '13
    Not concerned at the 'mo as it's working like a charm for me.
    ( MBP 8,2 Quad 2,4/8gb/Samsung EVO 750gb )
    I never chase the "latest and greatest" unless there is a specific reason to do so.

    MM.
     
  8. T'hain Esh Kelch macrumors 601

    T'hain Esh Kelch

    Joined:
    Aug 5, 2001
    Location:
    Denmark
    #8
    Check the Gigantic Samsung SSD thread. You'll get tons of information on this particular subject.
     
  9. k-hawinkler macrumors member

    k-hawinkler

    Joined:
    Sep 14, 2011
    #9
  10. ecschwarz macrumors 65816

    ecschwarz

    Joined:
    Jun 28, 2010
    #11
    Although checking the other thread will be your best bet for any questions in the future, here are the steps that should work the best:

    • Grab the firmware update here (the end result is a .iso file): http://www.samsung.com/global/business/semiconductor/samsungssd/downloads.html
    • Burn the .iso file to a DVD, not a CD or USB key
    • Boot from said DVD either by holding down 'C' or the Option key - should work from an external drive
    • Follow the on-screen prompts - it'll be a text-based tool that seems to be running on MS-DOS within a Linux boot partition

    For some reason, it just doesn't seem to work off of CDs and everyone has had mixed luck with flash drives. The Windows and Mac versions seem identical, although the file structure is a little different on the iso file - I actually used the Windows one without any trouble.
     
  11. A4orce84 thread starter macrumors 6502

    Joined:
    Apr 17, 2012
    #12
    Thanks guys! I appreciate the help and info! =)

    --Asif
     
  12. Marty62 macrumors 6502

    Joined:
    Mar 11, 2010
    Location:
    Berlin formerly London
    #13
    I just had the update to EXT0BB6Q work from burning the .ISO to a plain
    CDR - Verbatim was the make.

    However, the process seemed to fail and I had a "Software mismatch update failed" message.

    On reboot the correct new version EXT0BB6Q is listed in system.

    Weird, hopefully there was not an error and the update was flashed properly.

    M.
     
  13. jimtron macrumors member

    Joined:
    Jul 27, 2008
    #14
    Same thing just happened to me, got the firmware mismatch warning, said update was unsuccessful, but I also have the new version listed in system report. I assume that means the update worked, anyone else know about this?
     

Share This Page