Sandbox(1p42)?

Discussion in 'iPhone' started by phillipsteak, Jan 30, 2011.

  1. phillipsteak macrumors member

    Joined:
    Mar 28, 2008
    #1
    So I got my replacement iPhone 4 yesterday on firmware 4.2.1 and I jailbroke it using the tethered jailbreak. When I tried to log into gamecenter today using my apple account, it didn't recognize that I already had an account and tried to make me set up a new account. Near the top, it says"SANDBOX (1P42). Anybody know what this is and how to solve this problem?
     
  2. saving107 macrumors 603

    saving107

    Joined:
    Oct 14, 2007
    Location:
    San Jose, Ca
    #2
    I remember seeing Sandbox in GameCenter when iOS 4.1 was in beta, but sandbox went away when 4.1 went GM and was not present in iOS 4.2 betas.

    Unfortunately I don't know how to solve it, sorry.
     
  3. rickreiko macrumors newbie

    Joined:
    Nov 20, 2010
    #3
    My cousin just got a new one and her gamecenter was saying the same thing. I'm not sure what it means though.
     
  4. phillipsteak thread starter macrumors member

    Joined:
    Mar 28, 2008
    #4
    argh this is so frustrating! i just did a fresh restore and used the new greenp0ison and it still happens! :(
     
  5. Orion126 macrumors regular

    Joined:
    Aug 25, 2010
    #5
    Same here. It said I had to create a new profile.
     
  6. daidaic macrumors newbie

    Joined:
    Jun 22, 2009
    #6
    just jb to 4.2.1 yesterday and face the same problem as u :(
     
  7. SimpliQ macrumors newbie

    Joined:
    Feb 5, 2011
    #7
    The problem is because of the new AppSync 4.0+, probably hackulous will fix it at some point.
     
  8. TheDoctah macrumors member

    Joined:
    Aug 1, 2008
    Location:
    Brampton, ON
    #8
    Interesting...

    There are so many reason on the net...yet this one seems to make the most sense.
     
  9. phillipsteak thread starter macrumors member

    Joined:
    Mar 28, 2008
    #9
    That's what I thought too but ive tried uninstalling appsync and I still get the same problem. I also have a sandbox error when trying to restore my in app purchases :(
     
  10. opq macrumors member

    Joined:
    Dec 20, 2004
    #10
    Same problem after installing 4.2.1 and jb and AppSync 4.0+.... *subscribed*
     
  11. MtnMarkk macrumors newbie

    Joined:
    Feb 6, 2011
    #11
    this just also happened to me today. I had the 4.2.1 tethered JB and found the new untethered JB. I went on with it and all went well until I noticed this Sandbox problem. It's weird cause sandbox mode in GC is for developers, and I'm not even one :confused:
     
  12. fpena macrumors newbie

    Joined:
    Mar 30, 2010
    #12
    My case is different...
    I only have this problem with ONE app: Dungeon Defenders: First Wave
    Started to happen after I updated the game to it's last version...
    The other apps are working normal with gamecenter...

    I'm on jailbreak 4.1, btw...
     
  13. iMrNiceGuy0023 macrumors 68000

    Joined:
    Jun 5, 2009
    #13
    I had the same problem with a few of my iDevices this past weekend too.

    Just sign out of game center, start up a game that uses game center, exit that game, then log back into game center and your regular stats and everything should be the same
     
  14. opq macrumors member

    Joined:
    Dec 20, 2004
    #14
  15. FujiToast macrumors newbie

    Joined:
    Feb 7, 2011
    #15
    I've had this error all weekend. Ever since updating to 4.2.1 and jailbreaking with GreenPoison. I've tried logging in and out about 50 times, in all combination of restarts with no luck. I tried restoring 3 times with no longer either. The only thing the temporarily got me out of the sandbox was signing into game center after a restore but before the restore sync. But then I'd of course lose all my game saves and settings. So I ran the sync and once again...same thing. So if you don't mind starting completely over then maybe you can get your profile back but if not...then well it looks like you're stuck in the sandbox with me. Let 's how for a solution soon.
     
  16. opq macrumors member

    Joined:
    Dec 20, 2004
    #16
    FOR THOSE OF YOU WHO UPGRADED TO 4.2.1 - AVOID THE LATEST APPSYNC FROM HACKULOUS.

    - I had the same problem and had to restore and re-jb. But I managed to fix it, as per my post above.
    - I did 2 things differently - I used the latest version of Greenpoison (which apparently after 1 day was already 2 versions newer), and I didn't use AppSync 4.0+ (or anything from Hackulous).

    If you want AppSync, it seems like (as mentioned from the link I posted above as well) the consolidated 4.0+ version from Hackulous seems to break game center for me.

    I recommend a mirror Cydia Source, look for AppSync 4.2 from those. It worked forme.
     
  17. Mystikal macrumors 68020

    Mystikal

    Joined:
    Oct 4, 2007
    Location:
    Irvine, CA
    #17
    This. Its AppSync that causes Sandbox problems.
     
  18. phillipsteak thread starter macrumors member

    Joined:
    Mar 28, 2008
    #18
  19. FujiToast macrumors newbie

    Joined:
    Feb 7, 2011
    #19
    Can anyone else confirm that this worked for them? On one of my restores I tried accessing game center post jailbreak but pre installing ANYTHING and I still couldn't get out of the sandbox. But that WAS using an old GreenPoison since I of course didn't know it jumped two versions in two days ;). I'd just like to hear from any others before I go through all the work again! Thanks much! And thanks opq for the info. I hope it works for all!
     
  20. FujiToast macrumors newbie

    Joined:
    Feb 7, 2011
    #20
    Didn't work for me, :Mega sad face: Anyone else?
     
  21. FujiToast macrumors newbie

    Joined:
    Feb 7, 2011
    #21
    Anybody know if there is a jailbreak/appsync file of some sort that keeps getting restored when I restore my phone that could be breaking game center? I'm sure I could manually go in and change it if needed.
     
  22. wingsabr macrumors 6502

    wingsabr

    Joined:
    Dec 13, 2008
    #22
    Just wanted to post something that worked for me.

    1. Quit all apps
    2. Open GC
    3. Create dummy sandbox account
    4. Log out of dummy account
    5. Quit GC
    6. Start GC enabled game
    7. It should log you in to the dummy GC account
    8. Quit the game
    9. Open GC
    10. Sign out of dummy account
    11. Sign in to original account
    12. Start GC enabled game again to verify login updated

    Carry on.. ;)
     
  23. vantheman169 macrumors newbie

    Joined:
    Feb 20, 2011
    #23
    This worked first time. Thank you.
     
  24. AmplifiedLife macrumors newbie

    AmplifiedLife

    Joined:
    May 12, 2010
    Location:
    MPLStP
    #24
    Thank You... This Worked

    this worked for me the 2nd time. i skipped #4 the second time so i would stay logged in when i opened a GC enabled app. the first time, #4 forced me to login in to the GC app when opened, which started the process over again.

    so yeah, i skipped #4 but everything else went fine.

    THANK YOU!
     

Share This Page