Santa Rosa (Macbook Pro 3,1) and Snow Leopard keyboard issue

Discussion in 'macOS' started by PUTALE, Aug 30, 2009.

  1. PUTALE macrumors member

    Joined:
    Jul 29, 2008
    #1
    i just installed Snow Leopard today and found out that my old Santa Rosa Macbook Pro 3,1 keyboard no longer lights up. I am not sure if this is an issue with the new OS or my system. Anyone can confirm that if their keyboard lights up with the santa rosa MBP?
     
  2. BorjaNoise macrumors newbie

    Joined:
    Jun 11, 2007
    #2
    Hey, don´t call "old" our Santa Rosa ;) My keyboard light is working perfectly in Snow Leopard in my MBP 3,1...
     
  3. BikeRanger macrumors newbie

    Joined:
    Jul 10, 2008
    #3
    Still lighting (and unlighting) as usual on my Santa Rosa MBP. You probably checked already, but there's a setting for this in System Prefs > Keyboard.
     
  4. PUTALE thread starter macrumors member

    Joined:
    Jul 29, 2008
    #4
    mmh, that's odd. I saw that option and I was able to use my keyboard to check and uncheck the "illuminate keyboard". However, when I check that option and tries to use my keyboard's button to adjust the light, it won't let me adjust it (and not lighting up).

    Does that mean that the light is broken? I remember during installation the keyboard actually lights up but can't get it to work at all now>
     
  5. PUTALE thread starter macrumors member

    Joined:
    Jul 29, 2008
    #5
    MMH, just a follow up, i did some search and found how to reset the PRAM and reset teh SMC. It worked the first time, I can use the keyboard to turn on and off teh light. HOwever, today, it's not working anymore and even when I reset the SMC and PRAM, it's still not working.

    Just checking to see if the light is working, I download a tool taht allows me to manually adjust the light. It actually worked so the light on the keyboard is working. Not sure why I can't use keyboard to adjsut the backlit now.
     
  6. bezerk3r86 macrumors member

    Joined:
    Nov 3, 2008
    #6
  7. Maccleduff macrumors regular

    Joined:
    Jun 26, 2007
    #7
    When I upgraded my SR MBP to snow leopard, Software Updates ran, and I had a keyboard firmware update to install. A bit weird as its quite an old update and I thought it was previously installed. Maybe that could fix it for you though?
    http://support.apple.com/kb/HT1482
     

Share This Page