Sapphire Mac Edition w/ 10.10.3 Freezing Fixed?

Discussion in 'Mac Pro' started by Tucom, Apr 11, 2015.

  1. Tucom, Apr 11, 2015
    Last edited: Apr 11, 2015

    Tucom macrumors 65816

    Tucom

    Joined:
    Jul 29, 2006
    #1
    I know that there were serious issues with 10.10.2 and previous with the Mac Edition 7950 that caused whole system freezes and graphical anomalies. Fixed or no?

    Anyone having any issues at all with the Mac Edition 7950 and 10.10.3?

    This thread here mentions it -

    http://forums.macrumors.com/showthread.php?t=1864854


    I hop this thread isn't redundant, but any AMD 79.. users post any issues you have. I'd like to eventually get the 7950, but not with these issues.
     
  2. kgapp macrumors member

    Joined:
    Jan 6, 2004
    Location:
    Chicago, IL
    #2
    The Sapphire 7950 bug is not fixed in 10.10.3. It is possible that it's even worse but that is subjective. The only viable solution if you want to run Yosemite on a 7950 is to set Chrome as your default browser (shudder) and not even consider launching Safari.

    At this point I am not really sure we are going to see a fix. Apple knows it's there and hasn't addressed the issue in three dot updates released in over 6 months. Maybe we will get lucky and if there is a 10.10.4 it will bring an overhaul to graphics drivers to fix the AMD issue as well as add the missing Nvidia drivers to the base OS. I am not holding my breath though.
     
  3. alesi macrumors newbie

    Joined:
    Jul 2, 2010
    Location:
    Vigo
    #3
    My mac pro 5,1 with a sapphire 7950 mac edition works fine, no UI lag, no freeze, safari works fine and its all day open. On Os X 10.10.2.
     
  4. Plutonius macrumors 603

    Plutonius

    Joined:
    Feb 22, 2003
    Location:
    New Hampshire
    #4
    Sounds like another reason for me not to upgrade from 10.9 .
     
  5. kgapp macrumors member

    Joined:
    Jan 6, 2004
    Location:
    Chicago, IL
    #5
    Do me a favor. Go to www.funimation.com and see if it loads. If the home page loads click on 'watch' in the top toolbar. If you do not have a UI freeze doing that I will be quite surprised but very happy to know that it can be done.

    My 4,1 flashed to 5,1 with the sapphire 7950 freezes every time even with a fresh clean Yosemite install. Pull the 7950 or go back to Mavericks and everything works fine.
     
  6. alesi macrumors newbie

    Joined:
    Jul 2, 2010
    Location:
    Vigo
    #6
    It works well. I will install 10.10.3 on an external HD and see what happend, maybe tomorrow.

    [​IMG]
     
  7. kgapp macrumors member

    Joined:
    Jan 6, 2004
    Location:
    Chicago, IL
    #7
    Interesting. I thought all 7950 Yosemite users were affected but clearly that is not the case.
     
  8. alesi macrumors newbie

    Joined:
    Jul 2, 2010
    Location:
    Vigo
    #8
    I don't have flash or java installed, don't know if this is relevant.
     
  9. Jardins de Vin macrumors 6502a

    Jardins de Vin

    Joined:
    Nov 6, 2012
    Location:
    Europe
    #9
    I have the 7950 Mac Edition, I've been using it with Mavericks and now Yosemite since a few days. With Mavericks I got some weird grey stripes that appeared very quickly from time to time.

    I was told this could be a failing graphic card, but I was also told that this is typical for this card. Especially when using Youtube/Safari, and that's what I was doing.

    With Yosemite I don't seem to have this anymore, but then again it used to happen rarely on Mavericks so perhaps I haven't used Yosemite for long enough yet to find out if it's been happening or not. Been using Yosemite all day(s) long now, mainly browsing Safari (where the problem used to occur the most), and haven't noticed anything.

    The only thing that I get at the moment is the freezing in Safari, in text box areas (like the one I'm writing in right now – actually I just had this freeze) and it's quite annoying I must say. But so many people have it, I'm pretty sure it will be fixed in the next release.

    Other than that, I haven't tried any games or graphic intensive stuff.

    Don't think so, because I do get the freezes in Safari, but don't e flash or java installed either. In fact, my version of Yosemite is a fresh install, there's nothing installed on it yet.
     
  10. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #10
    Can you try to use smart zoom on that page as well?

    I use that as a test page for every OS update. So far, I occasionally able to load that page without any problem. However, once I use smart zoom, it's a guarantee freeze for me (may be up to 30s).
     
  11. Mr. Zarniwoop macrumors demi-god

    Mr. Zarniwoop

    Joined:
    Jun 9, 2005
    #11
    Works totally fine on a flash R9 280X.

    I can't seem to get make to the background-video version of that page when returning a second time though?
     
  12. Tucom thread starter macrumors 65816

    Tucom

    Joined:
    Jul 29, 2006
    #12
  13. mikeboss, Apr 16, 2015
    Last edited: Apr 16, 2015

    mikeboss macrumors 65816

    mikeboss

    Joined:
    Aug 13, 2009
    Location:
    switzerland
    #13
    after looking what files are updated, I'd say very unlikely. here's the standalone installer:
    https://support.apple.com/downloads/DL1807/en_US/OSXUpd10.10.3Supp.dmg

    EDIT:
    wow, this is annoying. the whole machine halts for a second or two. I just put a 7970 into my cMP to test this.
    just as predicted, this supplemental update does not cure this bug.
     
  14. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #14
    Just install the update and test it with funimation.com again.

    It improved a bit. Still freeze, but just a very short period of time (all less then 3 seconds in my test, and sometimes may be only half second). Before this update, the freeze could go up to 30s. However, it's still very annoying. I will still only use Safari for the known good website.
     
  15. kgapp macrumors member

    Joined:
    Jan 6, 2004
    Location:
    Chicago, IL
    #15
    It looks like www.funimation.com changed their design a bit in the last week or so. However, I still have the freezes on that site. My freezes are upwards of 60 seconds but I didn't get any at the home page (which I used to) only on one of the sub pages that listed the various videos.

    The micro freezes I am experiencing while typing out this post are INSANELY bad. I don't remember them being this bad prior to the 10.10.3 update and the supplemental graphics update.

    Back to Chrome for me. Safari is unusable in its current state with my 7950 installed.
     

Share This Page