SATA boot problem

Discussion in 'Mac Pro' started by kbear2, Jan 5, 2007.

  1. kbear2 macrumors newbie

    Dec 27, 2006
    My machine: Digital Audio G4 1.5Ghz/1.5 Ram/Radeon 8500

    Installed SATA controller and attached 500G Maxtor SATA drive and 320G SATA Seagate. Partitioned both to 80G for 10.3.9, 20G for OS9, rest for storage. Used SuperDuper (erase/backup all files) to clone other working 10.3.9 to both new drives. Seagate boots/reboots fine but once booted to Maxtor, drive runs normally but will no longer restart to itself. The only way to get to the Maxtor as boot drive is to boot to either the ATA bus or SCSI drive (running from UWMiles card) and then to the Maxtor. If I shutdown I can boot to the Maxtor, just a warm restart to itself or from the other SATA drive is not possible. Drive always mounts so that is not a problem.

    Have wiped drive several times, tried different partition schemes, cloned different systems, reinstalled X from scratch but result is the same. After initial boot to Maxtor, works as expected, but restart to itself is not successful, even from Terminal after reblessing (it shows as blessed in Terminal) and setBoot commands. Dumping caches or replacing BootX doesn't help either. SMART status is OK and running Disk Utility and TechTool Pro did not reveal any problems.

    Also tried switching cabling of SATA drives but no difference. Using Option key on startup gets me partially through the choices of boot drives but then screen freezes so I can't use that method.

    Any ideas?

    TIA. :)
  2. AlexMaximus macrumors 6502a


    Aug 15, 2006
    A400M Base
    some SATA controllers can not boot

    Hi my dear G4 friend,

    could you tell me what type of SATA controller do you exactly have?
    You may have a SATA controller that can not boot, meaning you can't use your SATA drive as a boot drive!
    I had a problem a couple weeks ago with my new SATA controller. I wanted to boot from my fast Raptor Drive and as it turned out my SATA controllers couldn't boot.
    However I was lucky and I got mine replaced with a different brand (fasttech) that can boot.
  3. SmurfBoxMasta macrumors 65816


    Nov 24, 2005
    I'm only really here at night.

    I've used Sonnet, Acard, Firmtek, and currently a SIIG SATA card(s) in a B&W (3), Sawtooth (2), DA, and QS's (2) and have never had any problems booting from any of my 4 hd's connected to them (Seagates, Maxtors, WD-Raptors etc) :eek:
  4. kbear2 thread starter macrumors newbie

    Dec 27, 2006
    This is the SATA card, from OWC. World Computing/SATAPCI2P/

    I have no problem booting to the other drive on the card (Seagate 320G) but getting to the Maxtor is like musical chairs. Sometimes when I shut down it boots up to it cold and twice I've been able to restart to it, but most of the time it opts to start to the Seagate, despite what is in the Startup Disk. And it is always reachable from the other buses (ATA, SCSI) directly. (EDIT: nope, not anymore, just restarted to Seagate from the ATA bus despite selecting Maxtor in SD).

    Since my previous posting I've run DiskWarrior and replaced the directories but that hasn't helped. This couldn't be a weak PRAM battery could it?

    Thanks for the input. :)
  5. SmurfBoxMasta macrumors 65816


    Nov 24, 2005
    I'm only really here at night.

    a weak pram battery can cause problems, so it would'nt hurt to replace it.


    A) Check system profiler to see the true identity of the card. Knowing OWC, it is probably built with either an Acard or Promise logic chips & boards. Acard chips are known to be 100% mac-compatible, Promise is known to be hit or miss. OWC knows macs inside & out, but perhaps they got hold of a few flaky boards/chips ?

    B) Check the jumpers on the maxtor, make sure it is set to master & not slave. Should'nt make any difference, since there are NO master or slave designations in the SATA specs, but it cant hurt to check......

    C) Zap the pram & nvram, if you havent already

    good luck :p
  6. roundeler macrumors newbie

    Jan 10, 2007
    In the same boat

    I got a Maxtor 500MB with OWC Sata controller. I can't seem to use it as a startup drive. Any luck with yours? -Mark
  7. roundeler macrumors newbie

    Jan 10, 2007
    Contacted OWC

    Tech support felt that the long spin up time of the Maxtor 500GB sata, and it is a piece of mass for sure, led to my G4 733 2001 QS not finding the drive in time. He suggested to hold down the option key and wait a few minutes for the drive to appear. Of course it never does for me, but this may work for you if you are patient. No matter for me once I'm setup, just makes transferring data an extra headache. I will be running the Sata as my main drive and getting rid of the IDE's, the Sata's are noticeabley quicker. Should help in Photoshop and iPhoto.

  8. kbear2 thread starter macrumors newbie

    Dec 27, 2006
    Smurfbox: Put in a new battery but that didn't help.
    Actually seemed to have made it worse as now I can't boot to it at all. Before I could from a restart or once in a while on boot.

    There are no jumpers for master/slave on SATAs, so nothing to check.
    And unfortunately System Prof does't show enough info to identify the card used.
    But thanks for the input.

    Mark: Thanks for your experience info.
    I never heard back from OWC and I have done all that I can do.

    I can't use the Option key on startup cause it freezes before it loads all the possible boot drives. The Maxtor does show as the selected drive but when the screen freezes I have to do a machine reset/restart which sends it over to the Seagate on the other SATA port.

    So I think I'm going to send the Maxtor back. I don't want a drive I can't use as my startup.
  9. kbear2 thread starter macrumors newbie

    Dec 27, 2006

    Wondering if it was the SATA card after all, I got a Sonnet SATA card, hooked up the Maxtor and it boots just fine. I left the Seagate on the OWC card (added another Seagate to it) so I'm rolling in hard drive space.


Share This Page