sata card won't work--any ideas?

Discussion in 'Mac Accessories' started by spinne1, Jan 25, 2007.

  1. spinne1 macrumors 6502a


    Mar 12, 2005
    Hermitage, TN USA (near Nashville)
    I've got a G4/533 Digital Audio and run 10.4.8. I bought a Siig sc-satm12 pci sata controller card off ebay. I then bought an sata hard drive. In Disk Utility, the drive would not successfully format or boot. I thought it was a faulty drive and eventually sent it in to Seagate for replacement. When I got the "fixed" drive from Seagate it did the same thing. Thinking it might be the drive and because I also need backup, I bought a different sata hard drive and installed it. Again Disk Utility cannot successfully partition the drive. Now I suspect the card. The card is sold all over the net as compatible with my system. I wonder what the problem could be. I have tried with all types of Mac OS formats, and with OS 9 drivers on and also off. For more detail from the attempted process of partitioning and then repairing the disk, here are my logs:

    Disk Utility started.

    Preparing to partition disk: “ST3400633AS”
    Partition Scheme: Apple Partition Scheme
    Mac OS 9 Disk Drivers installed
    1 partitions will be created

    Partition 1
    Name : “Untitled”
    Size : 372.5 GB
    Filesystem : Mac OS Extended (Journaled)

    Creating Partition Map
    Partition complete.

    Verify and Repair disk “disk3s10”
    Error: The underlying task reported failure on exit

    Disk Utility stopped repairing “disk3s10” because the following error was encountered:

    The underlying task reported failure on exit
    1 non HFS volume checked
    1 volume could not be repaired because of an error

    Mount of “disk3s10” succeeded

    [note that the disk did NOT mount despite the above]
  2. spinne1 thread starter macrumors 6502a


    Mar 12, 2005
    Hermitage, TN USA (near Nashville)
    Problem solved!

    I removed the Intech Hi-cap Support driver that is used to allow drives bigger than 128 GB to be read by older Mac computers and voila! it worked!

    The driver is incompatible with SATA cards apparently. Now I have to use just 128 gb of my PATA hard drive. No biggie. I got 300 GB and 372 GB sata hard drives installed and off I go.

Share This Page