Save as dialog beach ball, external hd ...

Discussion in 'macOS' started by Rinone, Oct 22, 2009.

  1. Rinone macrumors newbie

    Joined:
    Apr 26, 2009
    #1
    This is driving me nuts ...

    I have a 750gb FreeAgent external hard drive connected via usb. After some time it goes to sleep as it is inactive (I use it only for time machine backups!).

    When I open photoshop or after effects or when I initialize the save as / open in almost any app, a beach ball pops up and I can hear the external drive waking up from sleep, this lasts for 5-10 sec (the system is checking the drive(s)). This is so irritating. I don't want it to wake up nor do I want to save data to it (time machine backups only ...).

    Is there a way to stop the system from doing so ?

    Thanks in advance.
     
  2. djrod macrumors 65816

    djrod

    Joined:
    Sep 16, 2008
    Location:
    Madrid - Spain
    #2
    Apple Menu->System preferences->"light bulb icon"->"First tick option"

    I dont know the name of the option on mac os x english version, mine is in spanish, but that should do the trick 4 you.
     
  3. t0mat0 macrumors 603

    t0mat0

    Joined:
    Aug 29, 2006
    Location:
    Home
    #3
    Preferences -> Energy Saver -> Put the HD to sleep when possible

    Just unmount the drive if that doesn't work. Might need to do the above for noth battery and power adapter settings.
     
  4. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #4
    The option you want is in the Energy Saver pane (with the light bulb icon), and it's called "Sleep hard disks whenever possible". This will cause the disk to not go to sleep, ever, unless the computer goes to sleep.
     
  5. qoncept macrumors newbie

    Joined:
    Feb 4, 2009
    #5
    Brining a thread back from the dead.. I have the same issue, drives I rarely use but don't want to leave disconnected. I'll go ahead and turn off the sleep hard drives option, but I'd really prefer to be able to fix this without disabling it. My 4 external drives get noisy (at least compared to my iMac) and there's no sense in keeping drives that are mostly inactive fully powered all the time. May even affect their life.
     
  6. KKramer macrumors member

    KKramer

    Joined:
    Feb 9, 2010
    #6
    I am experiencing the same problem. Anyone know the solution?

    I have Snow Leopard. External FireWire HDDs attached, WD Studio II.
    The Hard disks go to sleep (spin down) after 5 minutes of inactivity.

    every time I use File>Open/Save dialog in any application it hands for 20 seconds while disks are waking up (spin up).
    This freeze also happens when I Right click any file in Finder and try to select "Open With" menu. before showing the menu Finder freezes until disks wake up.

    File Open/Save dialogs open by default in Documents folder on Internal HDD.
    There is no reason to access external HDDs until I navigate to them.

    And this does not happen with Time Capsule. If only Time Capsule is connected it stays in sleep mode and there's no pause for wake up.

    I don't believe this kind of problem is normal. Some setting/configuration in my system may cause this but I don't know what else to try.
    I tried adding and removing external disks form spotlight.
     
  7. Dragonforce macrumors 6502a

    Dragonforce

    Joined:
    Apr 9, 2008
    Location:
    London (Ealing) UK
    #7
    This IS normal for OS X.
    Even ejecting an internal HD on my Mac Pro will spin up again after a while.
    They even wake up when you do absolutely nothing, or as explained here with the "open / save" dialogue. It has been like that for years for me...
     

Share This Page