"Save as..." Finder popup delay

Discussion in 'OS X Yosemite (10.10)' started by chOse89, Oct 12, 2015.

  1. chOse89 macrumors newbie

    chOse89

    Joined:
    Oct 12, 2015
    #1
    Hello,

    I'm having a strange issue for a while now and I have no clue how to fix it.
    Each time I try to "Save as" a file from any application (Word, Excel, Photoshop, Chrome), I have to wait a few seconds (generally around 5s) in order to see the Finder popup appear, letting me choose where in my disk I wish to save the file.

    However, when I clic directly on the Finder icon in the shortcuts bar, it appears immediatly.

    This is even more disturbing since the computer is quite fast and has no other kind of lag. With an SSD disk, I'd expect an extreme fluidity with this kind of action!

    Anyone also has this problem? Thanks!

    Diagnostic :
    - I have no external USB drive of any kind plugged.
    - I'm only linked to my Internet network, I don't share any file et I face the problem whatever network I connect to.
    - I run on OS Yosemite (10.10.5) with i7 proc, 8GB RAM and 250GB SSD Disk.
     
  2. chOse89 thread starter macrumors newbie

    chOse89

    Joined:
    Oct 12, 2015
    #2
    Problem fixed, but no solved !
    Someone on another forum suggested I ran the console while trying to "Save as". Here is what appeared :

    12/10/2015 15:35:52,344 bird[40007]: created directory has a wrong owner (value: root, expected: macbookair)
    12/10/2015 15:35:52,344 bird[40007]: iCloud Drive is not able to run, please run "Repair Disk Permissions" in "Disk Utility"
    12/10/2015 15:35:52,345 com.apple.xpc.launchd[1]: (com.apple.bird[40007]) Service exited with abnormal code: 1
    12/10/2015 15:35:52,345 com.apple.xpc.launchd[1]: (com.apple.bird) Service only ran for 0 seconds. Pushing respawn out by 10 seconds.

    So I tried to Fix disk permissions, but with no success. I than disabled ICloud Drive, and now the lag is gone !
    I'd still wonder how to fix this without disabling ICloud Drive, since I might want to use it in the future.

    Cheers
     

Share This Page