Save SHSH?

Discussion in 'Jailbreaks and iOS Hacks' started by Grumpy232, Jun 17, 2012.

  1. Grumpy232 macrumors member

    Joined:
    May 26, 2012
    #1
    I asked this once before (in another thread, kinda hijacked it) so I thought I would give it it's own thread. I have a 4s thats on 5.0.1 (9A405) and 1.0.13. I was told to keep it at 5.0.1 instead of 5.1.1. Why did we wait for 5.1.1 for jailbreak for the 4s? This is to unlock for tmobile. So at this point what are my best options for using this phone on tmobil? Jailbreak at 5.0.1 and unlock, or upgrade to 5.1.1 and unlock? I realize that the unlock is unstable with 5.1.1, but has something changed? So this brings me to figuring out if I need to save the SHSH blob before upgrading (if I really need to upgrade this phone). I cant get tinyumbrella to install, seems to be java issues, I'm working that issue out in the mean time, thanks.
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    Update your java.
    It's always good to save all your available blobs.
    The only unlock for a 4S is by using a gevey.
     
  3. Grumpy232 thread starter macrumors member

    Joined:
    May 26, 2012
    #3
    Updated to latest java, no help. And I do get that I have to use a gevey, but do I stay on 5.0.1 or upgrade to 5.1.1? Did this on my daughters 4s, upgraded to 5.1.1 because I thought I had to. I'm getting conflicting info and want to confirm which platform to be on.
     
  4. Grumpy232 thread starter macrumors member

    Joined:
    May 26, 2012
    #4
    Ok, so I ran TU and found out that 5.0.1 isn't even supported by apple any more so I might as well update to 5.1.1 anyway and save the shsh for that version. I'm learning ;)
     
  5. ZCherub macrumors 6502a

    ZCherub

    Joined:
    Jul 7, 2010
    Location:
    GA, USA
    #5
    That's what you save SHSH's for in the first place - in case you want to downgrade to a firmware version that Apple no longer signs. You need to save your APTicket as well (should be the same process in RedSn0w).
     
  6. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #6
    Yes, there is a gevey that unlocks 5.1.1 for the 4S.
    Make sure you buy the correct one.
    The latest version of TU saves full blobs with apt ticket so in the future is possible you could restore/downgrade.
     
  7. Grumpy232 thread starter macrumors member

    Joined:
    May 26, 2012
    #7
    So lets say the next upgrade it to 6.0 and I upgrade and don't like, I would be able to do a restore back to 5.1.1. But as of right now, I can't restore back to 5.0.1?
     

Share This Page