Saving 4.01 SHSH Blob With a 3.1.3 iPhone?

Discussion in 'Jailbreaks and iOS Hacks' started by kevhui, Aug 23, 2010.

  1. kevhui macrumors regular

    Joined:
    Apr 24, 2008
    #1
    Hi,

    I have a iPhone GS running 3.1.3. I tried to use TinyUmbrella to save the 3.1.3 SHSH blob to Cydia but an error "not possible to sign" popped up.

    Using the advanced option, however, I was able to save 4.0, 4.01 SHSH blob. Is this real? I did not upgrade my iPhone any version higher than 3.1.3.

    Can I now "upgrade" to iOS 4.0 or 4.0.1 by running the TSS server?
     
  2. TMar macrumors 68000

    TMar

    Joined:
    Jul 20, 2008
    Location:
    Ky
    #2
    You can only save them while Apple is signing them and yes you don't have to be on a certain FM to save it as long as it is still being signed. You could be on 2.0 and save a blob for 4.0.2 right now.

    Edit: Your confusion has confused me. You couldn't have just saved just saved 4.0 or 4.0.1. If you were just able to request them then you got it from cydia's server and not Apple's which means that at some point cydia's server requested them for you. Are you Currently JB on 3.1.3?
     
  3. kevhui thread starter macrumors regular

    Joined:
    Apr 24, 2008
    #3
    Sorry for the confusion TMar.

    No my 3.1.3 is not a JB one. And when I used the advance option of TinyUmbrella, I selected Cydia in the "Requested from" field. The error "not possible to sign" appeared in the TinyUmbrella log window, not from iTunes.

    What I wanted to do orginally was to save my 3.1.3 SHSH blob and use Jailbreakme.com to jailbreak it. Because I could not save my 3.1.3 SHSH, I wonder if now can option-click restore to 4.0.1, then jailbreak with Jailbreakme.com.

    Thanks again.
     
  4. TMar macrumors 68000

    TMar

    Joined:
    Jul 20, 2008
    Location:
    Ky
    #4
    No you would have to have your blobs saved for 4.0.1, which it sounds like you don't. The only firmware you could restore to is 4.0.2.
     
  5. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #5
    It really sounds like you have your 4.0 and 4.0.1 SHSHs on file in Cydia (and now on your computer). If that is the case, you should be able to restore to 4.0 and then jailbreak with JailbreakMe.com.
     
  6. TMar macrumors 68000

    TMar

    Joined:
    Jul 20, 2008
    Location:
    Ky
    #6
    Post #3, he was never jailbroken so no. I think he just saw it in the option and got confused on what it meant.
     
  7. kevhui thread starter macrumors regular

    Joined:
    Apr 24, 2008
    #7
    Yes I think so because I see SHSH files in my PC. Will try to restore to 4.0.1 later. Thanks.
     
  8. TMar macrumors 68000

    TMar

    Joined:
    Jul 20, 2008
    Location:
    Ky
    #8
    But you were never jailbroken? Had you ever used tiny umbrella before?
     
  9. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #9
    Perhaps his is a second-hand or refurbished iPhone? It's been known to happen.
     
  10. TMar macrumors 68000

    TMar

    Joined:
    Jul 20, 2008
    Location:
    Ky
    #10
    Now that your here, does cydia only request blobs when opened or will it continue to request if he was JB previously? With all the ECID's on file I would assume do the former..
     
  11. kevhui thread starter macrumors regular

    Joined:
    Apr 24, 2008
    #11
    Sorry for my poor English.

    I tried jailbreak before but that was on my other iPhone 2G and iPad.

    This iPhone 3GS 3.1.3 has never been jailbroken before.

    I used TinyUmbrella to restore my iPad 3.2.1 and use Jailbreakme.com to jailbreak it. But my iPad was with 3.2.1 when I used TinyUmbrella to save my SHSH.

    For this iPhone 3GS cases, it is with firmware 3.1.3. But when I tried to save the SHSH (selecting Cydie for Request From field), TinyUmbrella showed the error "not able to sign".

    I want to retore my iPhone 3GS to 4.0.1 (because Cydia and locally I saved the SHSH blob), then Jailbreak it.

    I just tried but when I option-click Restore in iTunes, an error 3014 popped up. I have modified my host file to include a line "74.208.10.249 gs.apple.com" already :-(
     
  12. crawfish963 macrumors 6502

    crawfish963

    Joined:
    Apr 16, 2010
    Location:
    Texas
    #12
    I don't think you can upgrade to 4.0.1 since Apple is no longer signing it and you didn't have blobs for your device on file. Sorry mate.
     
  13. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #13
    You are correct, once the ECID is on the request hashes list, all subsequent firmware hashes continue to get saved, even if the device ceases to be jailbroken.
     
  14. kevhui thread starter macrumors regular

    Joined:
    Apr 24, 2008
    #14
    This is sad news:-(

    I was thinking when I used TinyUmbrella to save SHSH files locally, I would be able to restore to the (current version -1).

    So I need to wait when jailbreak 4.0.2 becomes available, hopefully it won't take long.
     

Share This Page