Saving to PDF triggers mount of encrypted file system.

Discussion in 'Mac OS X Lion (10.7)' started by NanoNyrd, May 2, 2012.

  1. NanoNyrd macrumors regular

    Joined:
    Dec 1, 2011
    #1
    Hi,

    I have an encrypted file system, made in the Disk Utility, and residing in a sparse bundle (i.e. a file-like thingy) on my normal harddisk. When I need it, I just mount it by clicking on it. Once, I made the mistake of printing a web page directly to PDF, and placed it in the encrypted file system. Now, EVERY time I try to print something to PDF from Safari, it wants to mount the encrypted file system. There is no way to not doing it, it just keeps popping up windows asking for the password! :mad:

    There must somewhere be a list of past directories that is used when saving PDFs. I have tried grepping all .plist files for the name of the encrypted file system, without luck. Does anyone know where it is stored, or how to clear it?
     
  2. robgendreau macrumors 68030

    Joined:
    Jul 13, 2008
    #2
    First, I'm assuming you mean Print to PDF, not Save as PDF. The Print to PDF application resides in Library/Printers/ I think that it's prefs are com.apple.printerproxy... or something like that. In any case I think if you removed the app and reinstalled it you might be able to nuke the default save location.

    Or use save as pdf.
     
  3. NanoNyrd thread starter macrumors regular

    Joined:
    Dec 1, 2011
    #3
    Yes, I meant print to PDF (although from the print popup, it actually says Save as PDF).

    I found another solution, attempting to solve another annoyance at the same time. I just made a new encrypted file system with another name, and copied everything. Problem solved, although in a not very elegant way ;)

    Thank you very much for your reply.
     

Share This Page