Saving Username/Password in Safari

Discussion in 'Mac Apps and Mac App Store' started by Hls811, May 17, 2007.

  1. Hls811 macrumors 6502a

    Hls811

    Joined:
    Apr 19, 2004
    Location:
    New Jersey
    #1
    OK, this one has stumped me... I am a member of a few site/forums, and for some reason one of them that I go to regularly stopped saving the username/password.. Its not the site, because on my other computers it is saved - so its not that its being blocked (and I am checking the 'Save password' box).. Its just from my MBP. And its only that one site.. It'll stay in place if I close the window, but once I exit out of Safari, I need to re-enter it. My UN/PW info saves here at MacRumors without any problem, as it does for any other forum I go to.

    I tried File > Empty Cache and File > Reset Safari, but no luck - still won't save for that one site..

    Is there anything else I can clear out? (I have OnyX, ran through the cleaners there and it didn't help either)...

    Ideas?
     
  2. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #2
    Preferences -> AutoFill

    You might want to delete your keychain and start over again or that site just isn't giving you a cookie.
     
  3. Mpulsive81 macrumors 6502

    Joined:
    Jun 7, 2006
    Location:
    McKinney, TX
    #3
    Wow Safari has *never* populated any of my information even though they show in my keychain. The only thing it will do (which i think is awesome) is auto fill my information (name, address, city, state, zip, phone, etc) But so far as usernames/passwords, Camino did it for me all day, Safari never did from the get-go. I'll check on that autofill thing in Safari preferences though and see how that works out for me.
     
  4. Hls811 thread starter macrumors 6502a

    Hls811

    Joined:
    Apr 19, 2004
    Location:
    New Jersey
    #4
    Nope.. didn't work.. I tried the autofill prefernces before, but no luck.. Ijsut went into keychain, and the specific site doesn't show up - but I cleared out the InternetPasswords item, went back in and no luck...
     
  5. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #5
    Are cookies enabled? The site might give you a cookie that expires quickly.
     
  6. Hls811 thread starter macrumors 6502a

    Hls811

    Joined:
    Apr 19, 2004
    Location:
    New Jersey
    #6
    Cookies are enabled, tried with and without, but I don't think its the site - both my work PC and my home PC store the username/password information correctly.. its just from this one Mac its not working properly...
     
  7. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #7
    <----Stumped
     
  8. iMeowbot macrumors G3

    iMeowbot

    Joined:
    Aug 30, 2003
    #8
    On the page where this is happening, it wouldn't hurt to view the page's source and look for the word "autocomplete" (specifically, autocomplete=off). Some sites use that in the belief that it will improve security. I think that most mainstream browsers are now supporting this (that is, if Safari won't remember the field then your other browsers, by default, should act the same way unless they're old versions) but it can't hurt to look.
     
  9. Hls811 thread starter macrumors 6502a

    Hls811

    Joined:
    Apr 19, 2004
    Location:
    New Jersey
    #9
    Nope.. interestingly enough, it doens't even let you view the source unless you're logged in! (Which I can do manually) - but nothing in there about Autocomplete (or anything similiar).

    Still stumped!
     

Share This Page