SB-600 whining sound

Discussion in 'Digital Photography' started by epicwelshman, Jun 14, 2008.

  1. epicwelshman macrumors 6502a

    epicwelshman

    Joined:
    Apr 6, 2006
    Location:
    Nassau, Bahamas
    #1
    Ok, so you know that sound external flashes make when they charge? That high pitched whiiiiiiiiiiine?

    My SB-600 is making that noise with freshly charged batteries all the time. I was photographing an event the other week and I had charged my batteries the night before, but they kept running out during the event. I think that was an issue with the rechargeable batteries (they were quite old) rather than the flsh.

    Since then, I got another set of rechargeables, and the flash seems to work ok, but constantly has that horrible whine.

    I know something must be wrong, but is it a serious problem?
     
  2. futuremac macrumors member

    Joined:
    Jun 2, 2008
    Location:
    Melbourne, Australia
    #2
    I don't know, but my rechargeable Ni-MH batteries didn't last long at all. I think they may be a bit old, but I only ever charged them 20 times. Even if I left the camera off for one night the batteries will be dead in the morning. If anyone has luck with a particular type of rechargeable please tell! My cheap Ikea LR6 batteries go ten times longer.
     
  3. epicwelshman thread starter macrumors 6502a

    epicwelshman

    Joined:
    Apr 6, 2006
    Location:
    Nassau, Bahamas
    #3
    I tried some regular duracell batteries in the flash, and it worked fine with no whining. I guess it was my rechargables that needed replacing. Thank goodness, i really didn't want to have to buy a new flash.
     

Share This Page