Scanner USB power problem

Discussion in 'Mac OS X 10.3 (Panther) Discussion' started by The Void, Jun 14, 2004.

  1. The Void macrumors regular

    The Void

    Oct 29, 2003
    I've just got a new 17" PB, and my Canoscan N650U doesn't want to play.
    I have Canoscan toolbox running under classic, which worked fine on my G4 Powermac, but now i just get the message "Scanner is not connected. Connect scanner.".

    Will my PB not provide the power for the scanner from its USB ports?

    If not, what are my alternatives?

    The scanner doesn't have a power lead, just USB. Am i going to have to buy a new scanner?

    Thanks for any suggestions,

    The Void
    Rotation Nationeer
  2. The Void thread starter macrumors regular

    The Void

    Oct 29, 2003
    I did try installing a driver program when i first switched to OS X, and that one totally screwed up my mac so that it wouldn't even boot. I can't remember exactly which one it was, but my suspicion is that it was this one. It turned out that "Mac OS 10.1.3 or higher" actually meant "OS X 10.1 version 3 or higher" and didn't work in Jaguar.

    Have you installed this yourself? What OS are you running?

    The Void
    Racketless elbows
  3. jeremy.king macrumors 603


    Jul 23, 2002
    Fuquay Varina, NC
    ScanExpert is an Application (with drivers) that should run in OS X - as in no need for classic. Are you sure you tried this and not the classic driver?
  4. The Void thread starter macrumors regular

    The Void

    Oct 29, 2003
    Yes. The OS X option didn't work for me, that's *why* i (was) running the classic version.

    I'm perfectly happy to use Classic for scanning - because it worked! Only it doesn't anymore :-(

    I think it's a USB power problem rather than a driver one. I forgot to say that it makes no difference whether or not i have my power adaptor plugged in.

    So kingjr3 - have you installed and run this program - and on what system?

    The Void
    Hot wrists
  5. 7on macrumors 601


    Nov 9, 2003
    Dress Rosa
  6. osprey76 macrumors 6502

    May 3, 2004
    Oklahoma City, OK
    I use VueScan for a fairly old UMAX SCSI scanner and it works well. I would try that. If VueScan won't work, it may be a USB power problem like you mentioned. I don't know where to find exact power specs for each of the computers, but I could easily see there being less power to send out over the USB bus from the PowerBook. A solution to that might be to run the scanner through a powered hub. Maybe that would get the scanner the juice it needs.

Share This Page