Scheme Compiler

Discussion in 'Mac Programming' started by CaptainZap, Apr 30, 2008.

  1. CaptainZap macrumors regular

    Joined:
    Jan 17, 2007
    #1
    I'm curious about Scheme and am trying to install Chicken for a compiler and so far I am not having any success on making it and installing it. I ran
    Code:
    sudo make PLATFORM=macosx ARCH=universal
    and I got this
    Code:
    ld: library not found for -ldylib1.10.5.o
    ld: library not found for -ldylib1.10.5.o
    collect2: ld returned 1 exit status
    collect2: ld returned 1 exit status
    lipo: can't open input file: /var/tmp//ccyJaoh0.out (No such file or directory)
    make[1]: *** [libchicken.dylib] Error 1
    make: *** [all] Error 2
    If you have an answers, thanks.
     
  2. lee1210 macrumors 68040

    lee1210

    Joined:
    Jan 10, 2005
    Location:
    Dallas, TX
    #2
    Here are the steps I followed:
    Downloaded the tar.gz, and unzipped it to a folder on my desktop.
    In the terminal, changed into the directory the archive was unzipped to.
    Ran:
    Code:
    make PLATFORM=macosx PREFIX=/users/MYUSERNAME/Desktop/ckn
    make PLATFORM=macosx PREFIX=/users/MYUSERNAME/Desktop/ckn install
    I then moved into /users/MYUSERNAME/Desktop/ckn/bin and created a file called test.scm with this:
    Code:
    (begin
      (display "Hello, World!")
      (newline))
    I then ran:
    Code:
    ./csc -o test test.scm
    ./test
    And got the output:
    Code:
    Hello, World!
    I didn't use arch... it didn't seem like I had to. It took about 4-5 minutes (Mario Kart Wii was thankfully at hand to fill the time) to run the first make, otherwise everything was pretty fast. I think the only reason you'd need sudo is if you wanted it to install in /usr/bin or something like that.

    -Lee

    Note: This is on 10.4, on an intel machine.
     
  3. CaptainZap thread starter macrumors regular

    Joined:
    Jan 17, 2007
    #3
    K, thanks it worked, although I'm still a little confused on why I couldn't install it the first time.
     

Share This Page