Screen dimming by itself when set not to: VERY annoying bug

EvryDayImShufln

macrumors 65816
Original poster
Sep 18, 2006
1,092
1
Am I the only one who has this problem? I set my screen so that it will not dim itself before sleep, yet it still does this. Tiger used to have the same problem, and now Leopard has it to an even further degree. At least with Tiger, it would do it, but going into settings and ticking it on, then off, would temporarily fix the problem.

Does anyone else have this problem? Does anyone know of a fix?
 

Mindflux

macrumors 68000
Oct 20, 2007
1,989
1
Austin
Am I the only one who has this problem? I set my screen so that it will not dim itself before sleep, yet it still does this. Tiger used to have the same problem, and now Leopard has it to an even further degree. At least with Tiger, it would do it, but going into settings and ticking it on, then off, would temporarily fix the problem.

Does anyone else have this problem? Does anyone know of a fix?
That's DIM BEFORE SLEEP. Not dim when inactive. AFAIK.
 

EvryDayImShufln

macrumors 65816
Original poster
Sep 18, 2006
1,092
1
That may be so, but it is still unticked meaning it should not happen, yet does anyway.
 

Mindflux

macrumors 68000
Oct 20, 2007
1,989
1
Austin
That may be so, but it is still unticked meaning it should not happen, yet does anyway.
Dude. What is it? That tick box is to tell your system to dim the screen before your system goes to sleep. It has nothing to do with inactivity dimming, as far as I know. From what I read is the dim before sleep happens in half the time your sleep setting is. So if your Mac goes to sleep an hour after inactivity, the dim function should not kick in until 30 minutes of inactivity has passed.
 

EvryDayImShufln

macrumors 65816
Original poster
Sep 18, 2006
1,092
1
Yeah but what I'm saying is I've INACTIVATED the function to dim the screen before sleep. Forget about inactive dimming, I NEVER want my screen to dim, and even when i UNTICK it, it still happens.

Anyhow my temporary solution is to set the screen sleep to "never". But honestly, it's a very annoying bug because when I want my computer to stay on overnight I definitely don't want my screen to be on. And I dont want the screen to dim after 5 minutes (when screen sleep is set to 10) even if I'm not using my computer, because I may still be referring to a graph or something during that time.
 

Mindflux

macrumors 68000
Oct 20, 2007
1,989
1
Austin
Yeah but what I'm saying is I've INACTIVATED the function to dim the screen before sleep. Forget about inactive dimming, I NEVER want my screen to dim, and even when i UNTICK it, it still happens.

Anyhow my temporary solution is to set the screen sleep to "never". But honestly, it's a very annoying bug because when I want my computer to stay on overnight I definitely don't want my screen to be on. And I dont want the screen to dim after 5 minutes (when screen sleep is set to 10) even if I'm not using my computer, because I may still be referring to a graph or something during that time.

Yes, but the dim before sleep and inactive are entirely different functions as far as I'm concerned.

Turn your screen sleep to never, and then set a hot corner to sleep when you move the mouse into the corner. problem solved until apple 'fixes' the issue. :confused:
 

kolax

macrumors G3
Mar 20, 2007
9,186
115
I get that aswell. It is a known problem by Apple - they state that after a restart you have to tick and then tick off the box.

That was for Tiger though (the article is on the Apple website somewhere), I'm disappointed they haven't fixed that for Leopard.
 

gorby

macrumors 6502
Oct 20, 2007
263
0
I get that aswell. It is a known problem by Apple - they state that after a restart you have to tick and then tick off the box.

That was for Tiger though (the article is on the Apple website somewhere), I'm disappointed they haven't fixed that for Leopard.
cool, glad i'm not seeing things then

i just shut off/on my new imac for the first time since i got it and experienced this

it's a minor 'issue' if there ever was one, but it should be a simple fix...? and it's been around for a long time apparently
 

Mister Ed

macrumors newbie
Dec 27, 2007
8
0
Work-around for Mac Screen Blanking Bug

My laptop was doing the identical thing after upgrading to Leopard.

Here's what fixed mine:
1) Open System Preferences> Energy Saver
2) Select "Settings for:" Power Adapter (Pull-down menu).
3) Run both sliders to Never.
4) Close System Preferences.
5) Repeat steps 1 though 3, except run the sliders back to what you wanted.
6) Close System Preferences.

Hope this works for you too!
 

Mister Ed

macrumors newbie
Dec 27, 2007
8
0
Alternate Work-around for Screen Blanking Bug

I read this work-around on another website:
1) Open System Preferences> Energy Saver
2) Options Tab> Other Options:
3) Uncheck Automatically reduce the brightness...
4) Reboot the Mac.
5) Repeat steps 1-4 except recheck the Automatically reduce the brightness...

I didn't try this method, since my Mac worked with the other fix.

Good luck!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.