Screen flicker all of a sudden then MBP stuck!

Discussion in 'MacBook Pro' started by Cixi, Feb 3, 2010.

  1. Cixi macrumors member

    Joined:
    Oct 16, 2008
    #1
    Hello everybody.

    I don't know if it depends by a latest update I did to Itunes but after an uncertain amount of time my MacBook Pro 2.2Ghz Santa Rosa start to flicker.

    I have posted a video in youtube http://www.youtube.com/watch?v=jRp69vCI0Mc so you can see what happend.

    For a small amount of time while flickering is started the mouse can move around then it stuck and lock me out of the system. I have to reset many time PVRAM and SMC then it will restart until it lock it down again!

    It worked flawlessly until yesterday after if I don't remember wrong one or more software update. I use Snow Leopard (official licence).

    I downloaded the Combo Update for Snow Leopard and ran it. I still have to test it again. Since I need to do some work in the next 48 hours I can't full test it.

    After the hard reset an image pop out
    [​IMG]
    and It won't let me start up the system again ever if I reset many times PVRAM and SMC

    Then I use bootcamp to "unlock" the MBP.
    I do run windows under BootCamp.
    It will run but I can't see anything since the video remain black (I hear the HDD until stop working)
    Then I push the power down button and I turn off the windows
    Then after a long time it will log into Snow Leopard!!

    I'm getting crazy the last two days!
    Can anyone help me to understand what the cause can be?
    Thank You all.
     
  2. Cixi thread starter macrumors member

    Joined:
    Oct 16, 2008
    #2
    Update...

    I swapped into Win XP... using BootCamp!

    I got the same flickering.

    It is not a RAM problem since I tested with different RAM Modules and my MBP did the same job. The video started to flicker.

    So now I have this:

    While under Snow Leopard
    While under Windows XP using Bootcamp

    the video start to flicker.

    I left today Win Xp with a flickering video for about 30 minuts running and I noticed that the video went back to normal but the mouse was surrounded by a flickering square and I could not use it.

    Do you think it depends on Video Card damage??
    I can't really think of something different.
    I exclude the RAM since I tested many configurations (2 Gb Apple RAM, 4Gb g.Skill single module, 5Gb - 1 Apple+4 g.skill, 1Gb Apple)

    I don't know what to think!
    Is there any software to test hardly my video card??

    Thank You
     
  3. Cixi thread starter macrumors member

    Joined:
    Oct 16, 2008
    #3
    Here is one of the many reports


    Interval Since Last Panic Report: 9151 sec
    Panics Since Last Report: 6
    Anonymous UUID: 110DA5EE-9276-4E06-9822-C178094CFD07

    Fri Feb 5 14:09:03 2010
    panic(cpu 1 caller 0x2a7ac2): Kernel trap at 0x009a925e, type 14=page fault, registers:
    CR0: 0x8001003b, CR2: 0x000000c0, CR3: 0x2764f000, CR4: 0x00000660
    EAX: 0x6e2735c0, EBX: 0x0a9c9004, ECX: 0x096f2020, EDX: 0x00000000
    CR2: 0x000000c0, EBP: 0x6e2735f8, ESI: 0x00000000, EDI: 0xffffffff
    EFL: 0x00010246, EIP: 0x009a925e, CS: 0x00000008, DS: 0x096f0010
    Error code: 0x00000000

    Backtrace (CPU 1), Frame : Return Address (4 potential args on stack)
    0x6e273388 : 0x21b2bd (0x5cf868 0x6e2733bc 0x223719 0x0)
    0x6e2733d8 : 0x2a7ac2 (0x591c30 0x9a925e 0xe 0x591dfa)
    0x6e2734b8 : 0x29d968 (0x6e2734d0 0x3 0x6e2735f8 0x9a925e)
    0x6e2734c8 : 0x9a925e (0xe 0x48 0x6e270010 0x9c0010)
    0x6e2735f8 : 0x9af6cb (0xc1d00001 0x1000000 0x1000003 0x40)
    0x6e273678 : 0x9d37bd (0x6e273808 0x9 0x0 0x0)
    0x6e2737d8 : 0x9d53f8 (0x0 0x600d600d 0x7027 0x6e273808)
    0x6e2738a8 : 0xb908e4 (0xc1d00001 0x1000000 0x1000003 0x40)
    0x6e2738d8 : 0xb9f110 (0x5956d000 0x1000000 0x88100090 0x3e)
    0x6e273938 : 0xba0dc6 (0x5956d000 0x1000000 0x15 0x5956d01c)
    0x6e273a48 : 0x972832 (0x5956d000 0x0 0x6e273b8a 0x80)
    0x6e273aa8 : 0x968796 (0xa06f400 0x0 0x6e273b8a 0x80)
    0x6e273bd8 : 0x9657ff (0xa06f400 0x9df1040 0x96392a 0xa06f400)
    0x6e273c98 : 0x954189 (0xa06f400 0x959304 0xa028b60 0x297241)
    0x6e273d08 : 0x950b98 (0xa06f400 0x6e273dcc 0xa7b8dac 0x213c78)
    0x6e273d38 : 0x534299 (0xa06f400 0xa7b8dac 0xa7b8dac 0x0)
    0x6e273d88 : 0x564c1c (0xa06f400 0xa7b8dac 0xa7b8dac 0x0)
    0x6e273de8 : 0x284dfd (0xa06f400 0xa7b8dac 0x0 0x0)
    0x6e273e58 : 0x21d65f (0xa33f568 0x96e6d84 0xa33f56c 0xa33f5a4)
    0x6e273e98 : 0x2107f7 (0xa33f500 0x6e273edc 0xa5a599c 0x6e273ed0)
    Backtrace continues...
    Kernel Extensions in backtrace (with dependencies):
    com.apple.NVDAResman(6.0.6)@0x96f000->0xc21fff
    dependency: com.apple.iokit.IOPCIFamily(2.6)@0x932000
    dependency: com.apple.iokit.IONDRVSupport(2.0)@0x961000
    dependency: com.apple.iokit.IOGraphicsFamily(2.0)@0x943000
    com.apple.iokit.IONDRVSupport(2.0)@0x961000->0x96efff
    dependency: com.apple.iokit.IOGraphicsFamily(2.0)@0x943000
    dependency: com.apple.iokit.IOPCIFamily(2.6)@0x932000
    com.apple.iokit.IOGraphicsFamily(2.0)@0x943000->0x960fff
    dependency: com.apple.iokit.IOPCIFamily(2.6)@0x932000

    BSD process name corresponding to current thread: WindowServer

    Mac OS version:
    10C540

    Kernel version:
    Darwin Kernel Version 10.2.0: Tue Nov 3 10:37:10 PST 2009; root:xnu-1486.2.11~1/RELEASE_I386
    System model name: MacBookPro3,1 (Mac-F4238BC8)

    System uptime in nanoseconds: 25222613640
    unloaded kexts:
    (none)
    loaded kexts:
    org.virtualbox.kext.VBoxNetAdp 3.1.2 - last loaded 23735955481
    org.virtualbox.kext.VBoxNetFlt 3.1.2
    org.virtualbox.kext.VBoxUSB 3.1.2
    org.virtualbox.kext.VBoxDrv 3.1.2
    com.google.filesystems.fusefs 1.7.1
    com.apple.driver.InternalModemSupport 2.6.0
    com.apple.filesystems.autofs 2.1.0
    com.apple.driver.AppleTyMCEDriver 1.0.1d8
    com.apple.driver.AppleUpstreamUserClient 3.1.0
    com.apple.driver.AppleHDA 1.7.9a4
    com.apple.driver.AirPort.Atheros 421.19.8
    com.apple.GeForce 6.0.6
    com.apple.driver.AppleLPC 1.4.9
    com.apple.driver.AppleGraphicsControl 2.8.16
    com.apple.driver.AppleBacklight 170.0.14
    com.apple.driver.SMCMotionSensor 3.0.0d4
    com.apple.driver.AudioAUUC 1.0
    com.apple.driver.ACPI_SMC_PlatformPlugin 4.0.1d0
    com.apple.kext.AppleSMCLMU 1.4.5d1
    com.apple.driver.AppleIntelYonahProfile 14
    com.apple.driver.AppleIntelPenrynProfile 17
    com.apple.driver.AppleIntelNehalemProfile 11
    com.apple.driver.AppleIntelMeromProfile 19
    com.apple.Dont_Steal_Mac_OS_X 7.0.0
    com.apple.driver.AudioIPCDriver 1.1.2
    com.apple.driver.AppleUSBTrackpad 1.8.0b4
    com.apple.driver.AppleUSBTCKeyEventDriver 1.8.0b4
    com.apple.driver.AppleUSBTCKeyboard 1.8.0b4
    com.apple.driver.AppleIRController 251.1.4
    com.apple.driver.CSRHIDTransitionDriver 2.2.4f3
    com.apple.iokit.SCSITaskUserClient 2.6.0
    com.apple.BootCache 31
    com.apple.AppleFSCompression.AppleFSCompressionTypeZlib 1.0.0d1
    com.apple.driver.AppleUSBHub 3.8.4
    com.apple.iokit.IOAHCIBlockStorage 1.6.0
    com.apple.iokit.AppleYukon2 3.1.14b1
    com.apple.driver.AppleFWOHCI 4.4.0
    com.apple.driver.AppleSmartBatteryManager 160.0.0
    com.apple.driver.AppleAHCIPort 2.0.1
    com.apple.driver.AppleIntelPIIXATA 2.5.0
    com.apple.driver.AppleUSBEHCI 3.7.5
    com.apple.driver.AppleUSBUHCI 3.7.5
    com.apple.driver.AppleEFINVRAM 1.3.0
    com.apple.driver.AppleRTC 1.3
    com.apple.driver.AppleHPET 1.4
    com.apple.driver.AppleACPIButtons 1.3
    com.apple.driver.AppleSMBIOS 1.4
    com.apple.driver.AppleACPIEC 1.3
    com.apple.driver.AppleAPIC 1.4
    com.apple.security.sandbox 0
    com.apple.security.quarantine 0
    com.apple.nke.applicationfirewall 2.1.11
    com.apple.driver.AppleIntelCPUPowerManagementClient 96.0.0
    com.apple.driver.AppleIntelCPUPowerManagement 96.0.0
    com.apple.driver.AppleHDAPlatformDriver 1.7.9a4
    com.apple.driver.AppleHDAHardwareConfigDriver 1.7.9a4
    com.apple.driver.DspFuncLib 1.7.9a4
    com.apple.driver.AppleProfileReadCounterAction 17
    com.apple.iokit.IO80211Family 310.6
    com.apple.nvidia.nv50hal 6.0.6
    com.apple.NVDAResman 6.0.6
    com.apple.iokit.IONDRVSupport 2.0
    com.apple.driver.AppleProfileTimestampAction 10
    com.apple.driver.AppleProfileThreadInfoAction 14
    com.apple.driver.AppleProfileRegisterStateAction 10
    com.apple.driver.AppleProfileKEventAction 10
    com.apple.driver.AppleProfileCallstackAction 20
    com.apple.driver.IOPlatformPluginFamily 4.0.1d0
    com.apple.iokit.IOFireWireIP 2.0.3
    com.apple.iokit.IOSurface 73.0
    com.apple.iokit.IOBluetoothSerialManager 2.2.4f3
    com.apple.iokit.IOSerialFamily 10.0.3
    com.apple.driver.AppleSMC 3.0.1d2
    com.apple.iokit.IOAudioFamily 1.7.2fc1
    com.apple.kext.OSvKernDSPLib 1.3
    com.apple.iokit.AppleProfileFamily 41
    com.apple.driver.AppleHDAController 1.7.9a4
    com.apple.iokit.IOGraphicsFamily 2.0
    com.apple.iokit.IOHDAFamily 1.7.9a4
    com.apple.driver.CSRUSBBluetoothHCIController 2.2.4f3
    com.apple.driver.AppleUSBBluetoothHCIController 2.2.4f3
    com.apple.iokit.IOBluetoothFamily 2.2.4f3
    com.apple.iokit.IOUSBHIDDriver 3.8.4
    com.apple.driver.AppleUSBMergeNub 3.8.5
    com.apple.driver.AppleUSBComposite 3.7.5
    com.apple.iokit.IOSCSIMultimediaCommandsDevice 2.6.0
    com.apple.iokit.IOBDStorageFamily 1.6
    com.apple.iokit.IODVDStorageFamily 1.6
    com.apple.iokit.IOCDStorageFamily 1.6
    com.apple.driver.XsanFilter 402.1
    com.apple.driver.AppleFileSystemDriver 2.0
    com.apple.iokit.IOATAPIProtocolTransport 2.5.0
    com.apple.iokit.IOSCSIArchitectureModelFamily 2.6.0
    com.apple.iokit.IOUSBUserClient 3.8.5
    com.apple.iokit.IONetworkingFamily 1.9
    com.apple.iokit.IOFireWireFamily 4.1.7
    com.apple.iokit.IOAHCIFamily 2.0.2
    com.apple.iokit.IOATAFamily 2.5.0
    com.apple.iokit.IOUSBFamily 3.8.5
    com.apple.driver.AppleEFIRuntime 1.3.0
    com.apple.iokit.IOHIDFamily 1.6.1
    com.apple.iokit.IOSMBusFamily 1.1
    com.apple.kext.AppleMatch 1.0.0d1
    com.apple.security.TMSafetyNet 6
    com.apple.driver.DiskImages 281
    com.apple.iokit.IOStorageFamily 1.6
    com.apple.driver.AppleACPIPlatform 1.3
    com.apple.iokit.IOPCIFamily 2.6
    com.apple.iokit.IOACPIFamily 1.3.0
     
  4. archre macrumors member

    archre

    Joined:
    Jan 10, 2010
    #4
    Jips quite looks as if your graphics card went to hell...
     
  5. maschinetheist macrumors newbie

    maschinetheist

    Joined:
    May 4, 2009
    #5
    I appear to have a similar issue. Any luck with calling Apple?
     
  6. Cixi thread starter macrumors member

    Joined:
    Oct 16, 2008
    #6
    All of a sudden the MBP will not fully run anymore!

    I power on, it start to load, then the Reset image as the one posted above appear!

    So I tried to let it start from USB but it does not! (I have an HDD with a fully working Tiger OS I used for testing purpose)
    When I start the MBP pressing and holding the ALT key it won't recognize the USB drive but only CD and internal HDD partitions.

    So believing the internal HDD could compromise the machine I pulled out the HDD, I left the MBP without the HDD and I tried to load it from Snow Leopard DVD but it hanged with the same reset image showed above.

    Then.... :mad: i formatted and cleared an old HDD and I pulled in to install the OS but... since the loading from DVD will not work.. this will not work

    :mad::mad:

    So I really guess it is something hardware related.

    And I guess I can't fix it easily unless I change Motherboard! Isn't it?!
    I'm really sad!!

    The worst thing is that if I'm going to buy a new MBP it is not worth since the new MBP series with I5 processor should pop out in a while!!
     
  7. tatehre macrumors newbie

    Joined:
    Oct 19, 2007
    #7
    I've got the same problem!!!! I have 2.4 Santa Rosa! That's is very strange!!!! Damn :apple:!!!! I will have to buy a new MBP soon!:)
     
  8. opinioncircle macrumors 6502a

    opinioncircle

    Joined:
    May 17, 2009
    #8
    I have the same problem on mine as well. But I used the SL DVD and Disk utility and seems like it works...Idk for how long tho :)
     
  9. Cixi thread starter macrumors member

    Joined:
    Oct 16, 2008
    #9
    Yes it worked for me the first two times... then... the system can't start at all with any DVD (Original Leropard DVD and Original Snow Leopard DVD!!)

    I'll bring to the apple center to see if they can do something about that..

    Few days ago.. I just bought new 4Gb memory to bring it to 5 AND a new battery!!!! Damn! I wasted 300 Dollars more or less!!
     
  10. sameon macrumors newbie

    Joined:
    Aug 7, 2008
    Location:
    London
    #10
    I had the same problem

    Genius found and diagnosed the famous nvidia graphics card issue.
     
  11. Cixi thread starter macrumors member

    Joined:
    Oct 16, 2008
    #11

    Is there any solution to this problem??

    Do you have any useful link to read about that?
    Thank you
     
  12. niuniu macrumors 68020

    niuniu

    Joined:
    Mar 29, 2009
    Location:
    A man of the people. The right sort of people.
    #12
    Had the same problem several times. I just did a reformat each time and it fixed it. I'm not techy so wasn't prepared to try and find out what the issue was at the time.
     
  13. Cixi thread starter macrumors member

    Joined:
    Oct 16, 2008
    #13
    Look at that...

    http://support.apple.com/kb/TS2377


    Monday I'll go claiming to be repaired for free!!
    I bought it in June 2007 so I'm still under warranty!! Yeaaaaah!!

    Thank You Sameon!!
     
  14. tatehre macrumors newbie

    Joined:
    Oct 19, 2007
    #14
    Wooohoooo! Ive bought it on September of 2007, so I should be able to fix it! Thanks!:):apple:
     
  15. Cixi thread starter macrumors member

    Joined:
    Oct 16, 2008
    #15
    Lucky me I have a video that shows the flickering video!!
    Otherwise I could not be able to demonstrate this!
    I've read many AASP are playing nasty tricks to not let it pass under warranty!!

    What bad persons!
     
  16. BrianMR macrumors regular

    BrianMR

    Joined:
    Apr 3, 2007
    Location:
    USA
    #16
    My Santa Rosa 2007 MBP just started failing very similarly, but just the lower 3/4s of the screen. Barely usable, then it usually gets better after 5-15 minutes. Holding out hopes of Arrandale bump -- I'll get a new one before I send this one off to warranty so I'm not computerless for a week or more.
     
  17. Cixi thread starter macrumors member

    Joined:
    Oct 16, 2008
    #17
    You better go immediately to a service center to get it repaired since it won't last long I guess if it is like mine!
     
  18. noodle654 macrumors 68020

    noodle654

    Joined:
    Jun 2, 2005
    Location:
    Never Ender
    #18
    I have the exact same thing, and it has to do with the nVidia 8600GT in the computer. I have the exact same model as you, the 2.2GHz, and mine died a few days. But right now it is running fine. I ran Apple Hardware test and it came up with no problems. However, I kept getting these horrible screen flickers where I could not control anything (computer froze) but the mouse was still movable. Eventually the flicker turned into blue lines down the screen. Restarted my computer and got a kernel panic with blue lines down the screen. It's an on and off issue, but it is definitely the GPU. I have a box coming here on Monday.
     

    Attached Files:

  19. Cixi thread starter macrumors member

    Joined:
    Oct 16, 2008
    #19
    What box?

    I hope on Monday I have not to fight against Apple tech man!
    I hate that.
    If they don't repair it I'll sue them!
     
  20. Cixi thread starter macrumors member

    Joined:
    Oct 16, 2008
    #20
    WTF!!! I just started again my MBP and guess what... it restarted!! Now I'm Installing on the new HDD I just swapped in so I can test it more!

    What is happening here???

    Can be the graphic card that discharge something while being not used or cooled down for a few hours?

    Damn Apple!!
     
  21. opinioncircle macrumors 6502a

    opinioncircle

    Joined:
    May 17, 2009
    #21
    You guys are getting me crazy worried here. Who has a Unibody Macbook Pro (June 09)?!!

    I'm asking because it seems y'all have another version...
     
  22. noodle654 macrumors 68020

    noodle654

    Joined:
    Jun 2, 2005
    Location:
    Never Ender
    #22
    Exact same thing here. I am using mine right now, but once the temp hits 140F my screen goes nuts and I cant get the computer running for hours. By box, if you have AppleCare and you call you can request them to do a mail in repair.
     
  23. MBP09 macrumors member

    Joined:
    Jun 9, 2009
    #23
    dont worry, i think this only relates to the older model (8600 GT).
     
  24. Cixi thread starter macrumors member

    Joined:
    Oct 16, 2008
    #24
    Right... it is related with old 2007 models I think with 8600 Nvidia card.:mad:
     
  25. Cixi thread starter macrumors member

    Joined:
    Oct 16, 2008
    #25
    I've got the whole motherboard replaced for free!! ;)
    Great!
    My MBP did not even complete the test to discover the bug. Was really buggy!

    ;)
     

Share This Page