Screen Goes Dim after 3-5 Minutes

Discussion in 'MacBook Pro' started by majordude, May 13, 2007.

  1. majordude macrumors 68020

    majordude

    Joined:
    Apr 28, 2007
    Location:
    Hootersville
    #1
    I pushed F2 and it is on full. I unchecked "automatically reduce the brightness of the display before display sleep" in Energy Saver... and the screen itself doesn't go to sleep unless the system is inactive for 15 minutes.

    When I am using the computer the screen is on full. If I let it sit around for a few minutes it gets dimmer (say 70%)... when I move the mouse it comes back on full.

    I'm stumped! :confused:
     
  2. ajhaji macrumors regular

    Joined:
    Aug 7, 2006
    #2
    I think that has to do with the power management. It's like a screen saver, in that it dims the screen to save energy when it's idle and then returns it to full power when you start using the computer again.

    Check in System Preferences, I remember there was a setting for it somewhere.
     
  3. majordude thread starter macrumors 68020

    majordude

    Joined:
    Apr 28, 2007
    Location:
    Hootersville
    #3
    That's what I thought too but I can't see anything other than the thing I unchecked above.
     
  4. ajhaji macrumors regular

    Joined:
    Aug 7, 2006
    #4
    I don't have a Mac around me so I can't check, but is there an option in the Screen Saver applet?
     
  5. cells macrumors newbie

    Joined:
    Apr 8, 2007
    #5
    Check the Energy Saver control panel. The option is "Automatically reduce the brightness of the display before display sleep"
     

    Attached Files:

  6. ajhaji macrumors regular

    Joined:
    Aug 7, 2006
    #6
    I think he already unchecked that option, as he mentioned in his original post. :p
     
  7. cells macrumors newbie

    Joined:
    Apr 8, 2007
    #7
    My bad. Make sure it's set for both Battery and Power Adapter?
     
  8. Lixivial macrumors 6502a

    Lixivial

    Joined:
    Jan 13, 2005
    Location:
    Between cats, dogs and wanderlust.
    #8
    This can be set by the CLI pmset utility. Typing:

    sudo pmset -c halfdim 0

    into the Terminal will disable the halfdimming state when you're on AC Power. To my knowledge there is no way to disable this via System Preferences, but I could have sworn there was a third-party GUI frontend for this. If you want to disable it for both Battery and AC Power you'd type:

    sudo pmset -a halfdim 0

    But I'd suggest leaving it enabled for when you're on the battery because it is a power savings item. It's also stored in /Library/Preferences/SystemConfiguration/com.apple.PowerManagement.plist

    Its plist entry is titled "Display Sleep Uses Dim" and the corresponding number will be whether it's on or off. 1 is on, 0 is off.

    EDIT: The checkbox that cells and the OP originally said controls this. It would appear I'm a bit slow today. :) I guess you could verify if that setting is actually being written to the plist file.
     
  9. cgi101 macrumors member

    Joined:
    Feb 13, 2006
    #9
    If the problem persists, take a look at the forums at support.apple.com

    I have an iMac that has this same problem... if I uncheck the screen dimming option, the screen won't dim anymore... until I restart the computer. After restarting, the option is still unchecked but screen dimming is back on (ie screen goes dim after 10-15 min of inactivity).

    There were lots of posts about this on the apple support forums. All possible solutions (clearing/deleting preference files, reinstalling OS X, updating OS X, manually changing settings using the pmset utility) did not correct the problem. I say it's a bug in OS X, but so many people seem to NOT have this problem in OS X.

    Anyways, try the pmset recommendations in this thread, and please let us know if it fixes the problem for you.
     
  10. coledog macrumors 6502a

    coledog

    Joined:
    Nov 14, 2006
    Location:
    Roanoke, VA
    #10
    Thanks for the pmset! It's worked so far for me!!
     
  11. majordude thread starter macrumors 68020

    majordude

    Joined:
    Apr 28, 2007
    Location:
    Hootersville
    #11
    Me too!
     

Share This Page