screen goes off when phone rings

Discussion in 'iPhone Tips, Help and Troubleshooting' started by mrjayd, Jun 26, 2009.

  1. mrjayd macrumors regular

    Joined:
    Jun 17, 2009
    #1
    I noticed now in 3.0 that when I get a call the screen comes on like normal to show who is calling but then after a couple of rings the screen goes blank but it still ringing unless I hit the home button again. Anyone else notice this?
     
  2. lfine39 macrumors member

    Joined:
    Mar 19, 2009
    #2
    Ditto here trying to find a pattern , doesn't happen all the time
     
  3. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #3
    That happened with 2.2, but OS 3.0 fixed it for me. you might want to do a restore.
     
  4. TSX macrumors 68030

    TSX

    Joined:
    Oct 1, 2008
    Location:
    Texas
    #4
    The only thing i can think of is that the light sensor is being blocked or in a shadow and it thinks its against your face.
     
  5. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #5
    Yeah, but mine would do that when I used the speaker. So, I don't think it's the sensor (at least not in my case).
     
  6. mrjayd thread starter macrumors regular

    Joined:
    Jun 17, 2009
    #6
    It never happened for me with 2.2 or 3.0 on my 3G phone. Just happenening with my 3GS and a restore won't do anything because i have done a few restores already for other things and the problem still exists.

     

Share This Page