Screen goes white using Chrome

Discussion in 'iMac' started by galileofigaro, Jun 15, 2012.

  1. galileofigaro macrumors newbie

    Joined:
    May 10, 2012
    Location:
    Orlando, Fl
    #1
    I have a 27" Imac bought just a couple of months ago. Runs OSX Lion 10.7.3, 3.4 GHz, i7, 4gb RAM, 1TB HD.
    I have a smugmug account and it bothers me when screen goes white sometimes when searching for photos.
    Same thing happens on Youtube. Screen goes white but I can hear audio from videos.
    Actually on any page, even Google, screen goes white.
    Every times this happens I go to Safari with no problems. So I need to have Safari open just in case the white screen issue occurs with Google Chrome.
    Thanks in advance!
     
  2. boto macrumors 6502

    boto

    Joined:
    Jun 4, 2012
    #2
    Make sure you update to the latest Chrome browser. If it still persists you can use beta version because sometimes there are coding errors and this occurs.
     
  3. wirelessness macrumors 6502

    Joined:
    Jun 20, 2010
    #3
    I get this a lot w/ Chrome. I've tried Beta and mainline releases and still get this issue regularly. I just force quit and restart which is really LAME!!! I need my web browswer to freaking work. I really the features of Chrome but am close to ditching it altogether.
     
  4. galileofigaro thread starter macrumors newbie

    Joined:
    May 10, 2012
    Location:
    Orlando, Fl
    #4
    Thanks!
    I installed the version 17.0.963.83. Imac loads pages much faster and white screen is gone, so far so good, except for googlemaps still a little slow to load maps. Have to find a solution to improve it.
    Thanks again!!
     

Share This Page