Screen issues - white-out and horizontal lines

Discussion in 'MacBook' started by model citizen, May 15, 2010.

  1. model citizen macrumors member

    Oct 25, 2009
    I'm having some issues with my Macbook. It's a mid '07 white Macbook with;

    2GB RAM
    320GB HDD
    GMA950 Video Card
    2.16 Intel Core 2 Duo
    Snow Leopard, updated.

    Nothing new or changed recently.

    The screen started by having the occasional 'white out' where it would be in use and a white screen would fade in for a few seconds then usually return to normal.

    Now, it would only do this sometimes so despite me taking it to Apple Care it didn't get fixed because when they ran it, nothing untoward happened. Recently it's gotten worse and there's now lines running across the screen too. Also, the mouse pointer will freeze where it is and I'll see a 'ghost mouse pointer' if you get me.

    I've tried to work out if it happens when I move it or if it's hot but it's very hard to tell. It might be happening more when the Macbook gets hot but I'm really not sure.

    I've managed to capture it on camera (it doesn't show up in screenshots) and I've included a couple of pictures - it's not showing up that great in the pictures but it's usually more white than this.

    Btw - although the pictures show Windows 7 being run, I hardly ever use Windows and so it's usually happened on OSX.

    Anyone have ideas as to what this could be?

    I'll take it to an Apple Store but I live pretty far away from one and it'll cost me significant money to get it there.



    Attached Files:

  2. gr3chan macrumors newbie


    May 15, 2010
    Several locations
    Do the lines change (get better or worse) when you move the display around? If you squeeze the side of the display where the lines are, do they change? It sounds like a possible LCD or LVDS cable issue. However, the "ghost" images from your pointer are not a symptom of the latter, but rather a video card issue. Hard to say without more information.
  3. model citizen thread starter macrumors member

    Oct 25, 2009
    Thanks for your reply.

    I don't think that moving it around changes anything as I've tried pinching it and tapping it then tilting the display but nothing different really happens compared to when I leave it alone - there's certainly no concrete cause and effect happening.

    Also this just happened, apologies if it's unrelated but I thought maybe not;

    I was looking at photos in finder and all of a sudden all my icons changed to the disc image icon, there was no more thumbnails and my documents were the same (btw - I've never messed with custom icons or anything like that).

    So thinking I better restart, I tried to restart but the screen just went solid white with very faint lines running from top to bottom. Also the status light that flashes when suspended, that was flashing but intermittently (not rhythmically like it should)

    After a hard power off, the macbook wouldn't come back on at all until around ten minutes later.

    One more thing - I was booted in windows 7 the other day and a similar thing happened, it hung on restart then acted as though it was suspended but at the time I assumed it was nothing.
  4. l.a.rossmann macrumors 65816


    May 15, 2009
  5. model citizen thread starter macrumors member

    Oct 25, 2009
    I finally got the chance to take it to an Apple Store and they said that since they weren't sure what was wrong with it, they'd install a new screen and a new logic board. I know this is probably a stupid question but is there any chance that they'd put in anything better than the crappy GMA950 that's in there?

    This is the third time I've had to take it in so hopefully it fixes it...

    Edit: Actually it's the fourth time I've taken it in.
  6. model citizen thread starter macrumors member

    Oct 25, 2009
    Okay so after almost two week's wait, I get the Macbook back and within an hours worth of normal use it becomes apparent that they haven't fixed it. Oh and now bluetooth doesn't work anymore - it says 'not available' (I tried network settings).

Share This Page