Screen Keeps Turning Back On

Discussion in 'MacBook Pro' started by humdrum, Mar 29, 2011.

  1. humdrum macrumors newbie

    Joined:
    Mar 29, 2011
    #1
    I have a MacBook Pro running 10.6.6 - the hard drive recently crashed and since I've gotten it back, for some odd reason the screen won't stay off. I dim it all the way and 5 minutes later it will come back on.

    The only way I can fix it is if I turn off the "automatically adjust brightness" option. Is there another way around this? any idea why this is happening? It wouldn't really matter, but I go to sleep with the computer on and it ends up waking me up every night.
     
  2. humdrum thread starter macrumors newbie

    Joined:
    Mar 29, 2011
    #3
  3. edifyingGerbil macrumors regular

    Joined:
    Feb 13, 2011
    #4
    you should be able to tell the OS when you want the screen turned off in the battery settings, no?

    ie, you can set it to turn off after 5 minutes or what have you.

    Have you done this and it still turns itself on?

    if so, I would then suggest just turning off the automatic brightness adjustment and then set the notebook to turn its screen off after 5/10/whatever.
     
  4. BCuz macrumors newbie

    Joined:
    Jul 16, 2011
    #5
    After having the same screen problems, especially going to bed at night and waking up spooked that my screen randomly turned on, I started messing with the power settings and seem to have isolated the problem. (This happened to me independent of the auto screen brightness setting under "Display")

    If you go into your System Preferences under Energy Saver, uncheck the "Automatically Reduce Brightness Before Display Goes to Sleep" option. That immediately fixed the screen from coming back on.

    If other folks want to confirm whether that works across the board, that'd be helpful in self-diagnosing this problem without input from Apple.
     
  5. djinnger macrumors newbie

    Joined:
    Oct 11, 2015
    #6
     
  6. djinnger macrumors newbie

    Joined:
    Oct 11, 2015
    #7
    I have the same problem where the darn thing pops on whenever it wants even after I got rid of the "wake for network access" thing. Problem is that I don't have an "Automatically reduce brightness before display goes to sleep" option under Energy Saver. iMac OS version 10.10.5 and I'm assured there are no updates possible.
     
  7. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #8
    That's because you're responding to a 4 year old thread, which relates to an earlier version of OS X that included that option. It is no longer available.
     
  8. djinnger macrumors newbie

    Joined:
    Oct 11, 2015
    #9
    Okay, my bad. But that doesn't solve the problem of my restless iMac.
     
  9. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #10
    Ignoring sleep for now - is there a noticeable delay (more than about 10 seconds) if you shut off your Mac?
     

Share This Page