Screen problems

Discussion in 'MacBook Pro' started by robinhoodexe, May 24, 2011.

  1. robinhoodexe, May 24, 2011
    Last edited: May 24, 2011

    robinhoodexe macrumors newbie

    Joined:
    May 24, 2011
    #1
    Hi :)

    Long time reader, first post. I'm having this nasty problem with my MBP from mid 2008. It's hard to describe, but take a look at this:

    [​IMG]

    It started suddenly this afternoon (live in EU) out of no where. Don't know what caused it really.

    I took the pic with my iPhone, since when i tried with the screenshot application in OS X, it only showed a black screen.

    I'm using a second monitor, but nothing changed when i unplugged that. I've also tried using the disc repair tool, nothing bad there either. Tried restarting, nothing happend. It looks a bit like screen tearing, but I've only experienced that in games such as world of warcraft and team fortress 2. Tried a virus test, found nothing (as if it ever had that).

    Here are my Xbench results (in case they can help):

    Results 200.90
    System Info
    Xbench Version 1.3
    System Version 10.6.7 (10J869)
    Physical RAM 4096 MB
    Model MacBookPro5,1
    Drive Type ST9320421ASG
    CPU Test 161.87
    GCD Loop 294.58 15.53 Mops/sec
    Floating Point Basic 115.52 2.74 Gflop/sec
    vecLib FFT 117.53 3.88 Gflop/sec
    Floating Point Library 240.87 41.94 Mops/sec
    Thread Test 307.32
    Computation 451.53 9.15 Mops/sec, 4 threads
    Lock Contention 232.93 10.02 Mlocks/sec, 4 threads
    Memory Test 181.78
    System 217.55
    Allocate 374.78 1.38 Malloc/sec
    Fill 165.28 8036.15 MB/sec
    Copy 197.19 4072.84 MB/sec
    Stream 156.12
    Copy 152.97 3159.55 MB/sec
    Scale 149.01 3078.46 MB/sec
    Add 162.63 3464.46 MB/sec
    Triad 160.65 3436.72 MB/sec
    Quartz Graphics Test 171.66
    Line 158.92 10.58 Klines/sec [50% alpha]
    Rectangle 195.18 58.27 Krects/sec [50% alpha]
    Circle 160.58 13.09 Kcircles/sec [50% alpha]
    Bezier 189.38 4.78 Kbeziers/sec [50% alpha]
    Text 161.19 10.08 Kchars/sec
    OpenGL Graphics Test 138.23
    Spinning Squares 138.23 175.35 frames/sec
    User Interface Test 249.17
    Elements 249.17 1.14 Krefresh/sec
    Disk Test 17.43
    Sequential 39.27
    Uncached Write 41.65 25.57 MB/sec [4K blocks]
    Uncached Write 48.74 27.57 MB/sec [256K blocks]
    Uncached Read 37.30 10.91 MB/sec [4K blocks]
    Uncached Read 32.77 16.47 MB/sec [256K blocks]
    Random 11.20
    Uncached Write 3.64 0.39 MB/sec [4K blocks]
    Uncached Write 37.91 12.14 MB/sec [256K blocks]
    Uncached Read 27.54 0.20 MB/sec [4K blocks]
    Uncached Read 50.22 9.32 MB/sec [256K blocks]


    Please help me :)

    Thanks in advance.
     
  2. NutsNGum macrumors 68030

    NutsNGum

    Joined:
    Jul 30, 2010
    Location:
    Glasgow, Scotland
    #2
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_1 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8B117 Safari/6531.22.7)

    Your machine appears to be suffering from Tetrisitis.
     
  3. robinhoodexe thread starter macrumors newbie

    Joined:
    May 24, 2011
    #3
    I'm probably being trolled hard now, but mind explaining? Google didn't help me at all :(
     

Share This Page