Screen sharing - Any way to disable the icon showing it is active?

Discussion in 'macOS' started by Passive101, Jan 21, 2009.

  1. Passive101 macrumors regular

    Joined:
    Dec 5, 2008
    #1
    Is there a way to disable the screen sharing icon in the upper right hand corner when screen sharing is being used?

    Any hacks for this?
     
  2. bigjnyc macrumors 601

    bigjnyc

    Joined:
    Apr 10, 2008
    #2
    uh oh someone wants to be a spy........just kidding :D maybe
     
  3. Passive101 thread starter macrumors regular

    Joined:
    Dec 5, 2008
  4. animaxcg macrumors regular

    Joined:
    Sep 10, 2008
    #4
  5. helpfulherring macrumors newbie

    Joined:
    Mar 5, 2009
    #5
    As long as you are the proprietor of the business and you NOTIFY your staff that you will be monitoring the computer due to abuses this is perfectly acceptable. You own the computer, and if you want to monitor it then that is your prerogative. To remove the icon from showing permanently the only option I know of is that you need to purchase the Remote Desktop software suite from Apple and in the preferences it has an option to disable the menu icon. A temporary fix is simply to command drag the icon off the menubar like you would an application from the dock. Poof. However this is only temporary and usable for ONE active session. As soon as you disconnect and then reconnect again, the icon will reappear.

    It would be nice if there was a way to permanently disable this button, but besides Remote Desktop, I don't know of one.

    If you are planning to use this for nefarious means remember that it is very possible for them to turn it around and put you in some real legal trouble. Don't invade peoples personal privacy, and don't be stupid. As long as you notify them that it should be considered a public and monitored computer, you should be fine.
     
  6. dwarde macrumors newbie

    Joined:
    Mar 25, 2009
    #6
    Yes!!

    This seems rather harmless but effective: Go to /System/Library/CoreServices/Menu Extras, and simply delete the file called RemoteDesktop.menu :D
     
  7. LambdaEnt macrumors newbie

    Joined:
    May 3, 2002
    #7
    From the Terminal:

    sudo chmod 000 /System/Library/CoreServices/Menu\ Extras/RemoteDesktop.menu

    enter password

    It works!
     
  8. labyrinth85 macrumors newbie

    Joined:
    Aug 22, 2011
    #8
    I just do a command drag off the menu bar.
    no hassle. no muss.
     
  9. karac54, Feb 4, 2012
    Last edited: Feb 4, 2012

    karac54 macrumors newbie

    Joined:
    Feb 4, 2012
    #9
    Karac54

    yes, Turn off all sharing in sharing prefernces that are on by unchecking ALL boxes. Log out and the icon should be gone in menu bar. After this is done you should be able to turn on what was turned off and the icon should still be gone, if not there is a connection to your computer.
     
  10. johnnymonster macrumors newbie

    Joined:
    Jun 27, 2012
    #10
    @labyrinth85

    omfg thank you for this trick i've been using macs for years and didn't know that! thank you.
     
  11. neurascenic macrumors newbie

    Joined:
    Jul 20, 2016
    Location:
    Colorado
    #11
    This appears to no longer work in el Capitan. any other options? root user will not even work.

    Thanks!
     
  12. Khitam macrumors newbie

    Khitam

    Joined:
    Friday
    #12
    How'd you undo it after?
     

Share This Page