Screen Sharing Authentication Issues

Discussion in 'Mac OS X Lion (10.7)' started by VitaminH, Sep 28, 2011.

  1. VitaminH macrumors newbie

    Joined:
    Apr 5, 2011
    #1
    Hi all,

    I've got a Mid-2010 MBP and a 2008 (maybe 2009?) Mini running as an HTPC. Both are running Lion. I had a fair amount of screen sharing and remote management issues on upgrade, but doing a clean install of Lion on the MBP seemed to resolve them. A few weeks ago now the Mini froze up on me doing something and I had to restart, I remember not being able to connect at all via file sharing, ssh, or screen sharing, but another reboot resolved it.

    Since that hiccup file sharing and ssh connect no problem with my username and password (no luck at all with an apple ID despite being setup as such, but that seems like it's a more common problem) but screen sharing is acting weird. I am 100% I am putting the password in correctly, and it'll work for file sharing or ssh, but every time it fails authentication on the first try to connect to screen sharing.

    Previously if I was connected I could just hit "share screen" and the screen sharing app would open up no problem, it now asks for a password with my username and always on the first attempt tells me authentication has failed. I can immediately type my password in again and it works. I thought for the first week or so I was just really bad at typing it or something but this is completely consistent. Every. Time. It always connects then no problem on the 2nd attempt. I tried changing the password on the Mini, and even made it very simple to be sure I was typing it correct, still fails on the 1st try every time. It still works after the second attempt but it's an annoyance with as much as a screen share to the Mini to control what I'm watching on TV to have to type my password twice every time when in the past I had just been clicking "Share Screen". Yes the box to "remember my password in keychain" is checked but the authentication window pops up regardless with the password field blank.

    I didn't think to try to delete the keychain file associated with this login, perhaps that'll help? I'll try that when I get home from work.

    Any other ideas or thoughts are welcome. Thanks.
     
  2. VitaminH thread starter macrumors newbie

    Joined:
    Apr 5, 2011
    #2
    Fixed, hopefully

    Replaying to myself for archival purposes in case anyone in the future has a similar problem. I opened up my Keychain Access and deleted any and all associations with that machine on the network. Logged in again, checking the box to remember this machine in my keychain and it worked on the first try and now lets me fire up screen sharing again over the network without having to authenticate every time.
     
  3. DanSkarbek macrumors newbie

    Joined:
    Dec 5, 2014
    #3
    Deleting KeyChain Entries Didn't Work For Me

    I've been having exactly the same problem: first authentication with Screen Sharing fails, but second one succeeds. I deleted all the entries from my keychain for the computer and tried again, but still getting the behavior. Do I need to reboot or do something more dramatic to kick it back into gear?
     

Share This Page