Screen Sharing problems after Lion upgrade

Discussion in 'Mac mini' started by m021478, Aug 13, 2011.

  1. m021478 macrumors 6502

    Joined:
    Nov 23, 2007
    #1
    I have a Mac-Mini at the heart of my home media center. For the last couple years when I needed to access the computer, I would simply use OS X's built in screen sharing capabilities, because the Mac-Mini doesn't have a mouse/keyboard connected to it.

    The problem I'm having with Lion is that when I try connecting to the Mac-Mini using the same screen sharing method I've used for years, I now get this pop-up message:
    [​IMG]
    Now, I do have two user accounts on the Mac-Mini and if I choose "Connect to a virtual display" I can connect to the 'background' user account of the mac-mini without any problems, but that's not the one I am trying to connect to.

    When I choose the option to "Ask to share the display", it won't let me connect unless I use the Mac-Mini to confirm that I want to allow this connection - which in my case isn't possible because there is no keyboard and mouse connected to the machine.

    Why is it that it won't allow me to connect to the currently signed in user on the Mac-Mini unless I confirm this from the mini itself? If I try using screen sharing to connect from iMac to my MacPro (or vice versa), both of which have only one user account on each machine, then I am able to directly connect and control either machine from the other without the need for any confirmation.

    Any thoughts on how I can get the Mac-Mini to allow me to connect without the confirmation? Do I have to delete the second user account so that the Mini is only running one user account?

    Any suggestions would be greatly appreciated... Thanks!
     
  2. tbayrgs macrumors 603

    tbayrgs

    Joined:
    Jul 5, 2009
    Location:
    Florida, USA
    #2
    I had the same problem when I converted both my Macbook and Mac Mini HTPC to Lion, except I only had a single user account on the Mini and the only way I could connect was via the first option on the pop up (virtual display option never connected) and having to give permission on the Mini defeated the purpose of screen sharing from the Macbook. I was unable to resolve the issue so I rolled the Mini back to SL and am now once again able to screen share without issue.

    I'll be curious to see what solutions are offered for your situation.
     
  3. audioborg macrumors newbie

    Joined:
    Aug 14, 2011
    #3
    Experiencing the same, exact issue here. Using a Mac Mini w/Lion as HTPC, and trying to use MacBook Pro w/Lion to screen share to/with the Mini. I can access the second account in the background, but not the main active account, which is what I want.

    Screen sharing my Mac Pro with 10.6.8 is working fine.
     
  4. nzreg macrumors member

    Joined:
    Nov 14, 2009
    #4
    On my late 2009 imac and macmini 2011 I use this menulet

    http://www.klieme.com/ScreenSharingMenulet.html

    Simplicity, just start menulet, an icon appears in menu bar, click on this and it will show you all the machines on your network, one more click and you are in.
     
  5. m021478 thread starter macrumors 6502

    Joined:
    Nov 23, 2007
    #5
    I already use this Menulet... from any of my computers, when I click on my Mac-Mini from the menulet's flyout menu, I encounter the problem above. he menulet fixes nothing. It's just another way of initiating the connection.

    Any other suggestions??
     
  6. BuffyzDead macrumors member

    BuffyzDead

    Joined:
    Dec 30, 2008
    #6
    I fixed it here

    I was having the very same issue on my son's Brand New Macbook Air.

    I am the administrator on his Air (one of the two user accounts) and he has a "managed account" with Parental Controls turned on (the second of the two user accounts.

    It's the exact setup I have for him on his iMac.

    I like to screen share blindly (without him providing me screen sharing permission) so I can monitor that he is in fact doing his homework, or his creative work, and in general, to keep tabs on him as he browses the internet, his Facebook account, etc.. He is 11 years old.

    All fine but, as described above by others, when I tried to screen share into his Air, I was getting the:

    "Ask To Share The Display" prompt.

    I don't want to ask, I want to do.

    After reading the above, I thought I had to delete the Admin account on the Air, and turn his managed user account, into an Admin account.
    Basically just run ONE account on the Air

    When I turn his managed parental control account into an Admin account, (required to delete the second Admin account), for giggles, I just tried screen sharing from my iMac 24" running 10.7.1, to the Air's new Admin account with my son's name.

    This time,
    A prompt came up with THREE radio buttons.
    I do not recall seeing that before.

    This time it said; 1) Connect by Asking Permission, 2) Connect as a registered user account, and 3) Connect to the Virtual Account (the other Admin account)

    I selected connect as a registered user, choosing my son's 'administrator enabled" account, using his user name and password.

    Voila, it connected WITHOUT a prompt on his screen (on the Air screen), giving me access.

    FINALLY,
    I toggled his admin account BACK to a managed parental account, and tried a screen sharing connection again.

    Voila !!, it again connected without asking for any one's permission.

    I'm sure it's a bug, or something, but now I can screen share from either of my two other iMacs to his managed, parental controlled account on the Air, WITHOUT any permission prompting.

    Works as I want it to.

    BTW,
    the other fix that works is just having a Single Admin User Account,
    on the machine you wish to screen share to.

    Your mileage may vary.
     
  7. DigiTrance macrumors newbie

    Joined:
    Nov 28, 2008
    Location:
    Kenosha, WI
    #7
    I think you need to select "Anyone may request permission to control screen." in Screen Sharing preferences to get the third option (to connect as a registered user, without asking).

    Even with this option enabled, the person connecting to the computer to share the screen needs to authenticate, so it's not like Joe Schmoe can connect to the computer and view the screen without asking.
     

Share This Page