Screen Sharing Trouble

Discussion in 'Mac Basics and Help' started by Ronnie Lama, Mar 17, 2014.

  1. Ronnie Lama macrumors newbie

    Joined:
    Sep 19, 2013
    #1
    Before I go into a long confusing story about what I've done to try and make this work, do I have to be on the same local network to screen share with someone? (cue long confusing story).

    I'm trying to screen share with my girlfriend, using the Screen Share app. We both have Screen Sharing checked in our System Preferences, Allow Access for All Users checked, and have a password set for VNC users, and "anyone may request permission to use screen" is checked as well.

    That being said, my girlfriend copied and pasted the "Other users can access your computer's screen at vnc://blahblahblah/ or by looking for “Ron’s MacBook Air” in the Finder sidebar." to me, and I typed in "vnc://blahblahblah/" into the text box for Host: in the Screen Share app. So reason dictates we should be able to connect, right? Am I missing anything? Because on my end, it'll say Connecting... but she won't get a notification or pop-up asking permission for me to connect or anything.

    Then my Connecting... window will say, "Please make sure that Screen Sharing (in the Sharing section of System Preferences) is enabled on the computer to which you are attempting to connect. Also make sure your network connection is working properly." We both have screen sharing enabled, and we are both using the internet, so I'm not sure where the issue lies.

    Can anyone offer any insight or help? I've attempted various searches online for solutions, but haven't found anything that has solved my problem. Any help at all would be awesome.

    P.s. I have a 2011 MacBook Air with OSX 10.9.2 and she just bought her MacBook Pro with OSX 10.9.2 as well.
     
  2. glenthompson macrumors 68000

    glenthompson

    Joined:
    Apr 27, 2011
    Location:
    Virginia
    #2
    If you're not on the same network you have to enable the VNC port on your router. When on the same network I only have to select "share screen" when the computer name is selected in the finder sidebar.
     
  3. Ronnie Lama thread starter macrumors newbie

    Joined:
    Sep 19, 2013
    #3
    Thanks for the tip! I enabled the port on my router, I just have to do so on my girlfriend's router now. Hopefully this will solve this issue!
     
  4. glenthompson macrumors 68000

    glenthompson

    Joined:
    Apr 27, 2011
    Location:
    Virginia
    #4
    You may also need to enable port forwarding on the router so it knows which internal address to send the VNC request to.
     
  5. 1934hotrod macrumors regular

    1934hotrod

    Joined:
    Jan 27, 2013
    Location:
    Woodstock
    #5
  6. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #6

Share This Page