Screen sharing ?

Discussion in 'Mac OS X Lion (10.7)' started by Resqu2, Jul 21, 2011.

  1. Resqu2 macrumors 6502a

    Joined:
    Apr 23, 2011
    #1
    Posting this for a member of a different forum I'm on, thanks for any help you can give.

    I found something that I am not really happy about. Now when you do a share screen it asks the other computer for permission. I use this a lot to monitor what my kids are doing. If anyone has a work around for this could you please let me know.

    Thanks.
     
  2. spoccka macrumors member

    Joined:
    Jan 1, 2010
    #2
    Wirelessly posted (Mozilla/5.0 (iPod; U; CPU iPhone OS 4_3_3 like Mac OS X; en-gb) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8J2 Safari/6533.18.5)

    What's the problem with letting them know you're snooping?
     
  3. Resqu2 thread starter macrumors 6502a

    Joined:
    Apr 23, 2011
    #3
    lol good question? I'm just posting the question for her.
     
  4. AdeFowler macrumors 68020

    AdeFowler

    Joined:
    Aug 27, 2004
    Location:
    England
    #4
    I use screen sharing to monitor a Mac in the next room... not spy on anyone. It would be nice to have an "always accept requests from ?????" option.
     
  5. gentlefury macrumors 68030

    Joined:
    Jul 21, 2011
    Location:
    Los Angeles, CA
    #5
    didn't do that to me...how are you logging in?

    Try going into safari and typing vnc://[ip address]

    it will log in and shouldn't disrupt anything...the only thing you will see is the remote login icon on the top bar.

    If it's local than just go into finder, select the mac you want to control and click share screen...it will log in with no question. I do this everyday and have done it since installing lion.

    If for some reason this doesn't work for you you can ssh tunnel...but you will have to look up instructions for setting that up.
     
  6. Glock26 macrumors newbie

    Joined:
    Jul 22, 2011
    #6
    I'm the OP of this question from the other forum. I am going into finder on sharing. With SL it would just show me the screen. Now it pops up a box on the computer I am connecting to asking to allow screen sharing.

    I'm going from a early `10 MBP running Lion to a late `10 IMac running Lion.

    ETA: I just checked and I can go from the IMac to the MBP without notification, but can not do it from the MBP to the iMac
     
  7. ooans macrumors 6502

    Joined:
    Jun 4, 2011
    #7
    For me this makes Safari crash instantly.
     
  8. AFPoster macrumors 65816

    Joined:
    Jul 14, 2008
    Location:
    Charlotte, NC
    #8
    are you all talking about Screen Sharing in iChat?
     
  9. Glock26 macrumors newbie

    Joined:
    Jul 22, 2011
    #9
    No screen sharing from finder.
     
  10. AFPoster macrumors 65816

    Joined:
    Jul 14, 2008
    Location:
    Charlotte, NC
    #10
    Cool
     
  11. dingamahoo macrumors member

    Joined:
    Feb 25, 2007
    #11
    I'm going from a 2007 Macbook to a 2009 Mac Mini and having this issue on both computers.

    On each one I have to get permission from the computer whose screen I want to control.

    This is an incredible pain in the ass. Both computers are mine and it's often very convenient to control the mini in the other room from my laptop. I can't believe they put this hitch in without a way to disable it.

    My hope is that this will change and soon. Will be interested to hear if anyone else has a solution or seen something that I have not.
     
  12. esy034 macrumors newbie

    Joined:
    Jan 23, 2008
    #12
    Solution

    I had the same problems until I found out you just use remote management on the computer that you want to connect to...instead of screen sharing. Once you set it up and turn on back to my Mac it all just works without any prompt to request sharing. Settings sharing remote management NOT screen sharing. Why don't they make this info available on support site? You do have to have a password if you leave password blank it doesnt seem to work. NO you do not need to purchase remote desktop management unless you want to see and administer all the computers on your network simultaneously. Make sure to either check all users or add your user name to the Users section of each computer that you want to connect to and choose to allow user to be administrator. The virtual screen does work but it is hit and miss for some reason unknown.
     
  13. esy034 macrumors newbie

    Joined:
    Jan 23, 2008
    #13
    Solved

    I had the same problems until I found out you just use remote management on the computer that you want to connect to...instead of screen sharing. Once you set it up and turn on back to my Mac it all just works without any prompt to request sharing. Settings sharing remote management NOT screen sharing. Why don't they make this info available on support site? You do have to have a password if you leave password blank it doesnt seem to work. NO you do not need to purchase remote desktop management unless you want to see and administer all the computers on your network simultaneously. Make sure to either check all users or add your user name to the Users section of each computer that you want to connect to and choose to allow user to be administrator.
     
  14. dingamahoo macrumors member

    Joined:
    Feb 25, 2007
  15. johnmike8940 macrumors newbie

    Joined:
    Apr 16, 2013
    #15
    That’s how it works. You can`t directly access any body’s else computer without their permission. This all screen sharing software's such as WebEx, gomeetnow, gotomeeting, on premise RHUB TurboMeeting appliances are used for.
     

Share This Page