Screen sleep issues solved

Discussion in 'PowerPC Macs' started by eyoungren, Jun 6, 2015.

  1. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #1
    For the last couple of months I've been dealing with an issue on my Quicksilver where when the screen turns off after the Mac is idle for some time it will wake. The cycle repeats over and over with my screen consistently waking/sleeping throughout the day.

    This has not been so great for my ADC displays as it means they are "on" all the time. To the point where I had to find a solution to a blinking light on the main display (I posted a thread on that).

    I attributed this to my Sonnet USB/FW combo PCI card because it started around the time I installed that card.

    Recently I have come home a few times to find my QS disconnected from my home network because the switch it is connected to has been powered off (stupid cat!). However, the last time or so I finally noticed something else. All of my displays were off! Like they are supposed to be!

    This suggested to me that my problem was NOT my Sonnet card, but something to do with my network settings. So, I poked around for awhile on the Mac and on Google but didn't really find anything. So I thought about it. The one thing I do with all my Macs on my home network is drive sharing.

    What the hell I thought. I'll shut off filesharing and see what happens. When I open the Sharing pane in System Preferences (which I have not done in a while I see some messed up permissions. Hmmm. So, I shut it off and immediately I get a note that filesharing will close in a moment. Only it doesnt. It won't shut off!

    So I decide that I am going to remove the drives that I am sharing from the pref pane (I can always add them back later). After removing the first drive, filesharing shuts down instantly! So, I remove the other drives and test my screen sleep.

    VOILA! My screens have been sleeping EXACTLY as they are supposed to every time the Mac becomes idle now! This tells me something went whacky with the filesharing. Later on I will add the drives back and turn it on again and see what happens (what is supposed to happen I believe) but for now my long standing problem has been solved!

    I thought I would post this here as another reference or help for others. If your Mac constantly wakes your screen and you've tried everything, check filesharing.
     
  2. poiihy macrumors 68020

    poiihy

    Joined:
    Aug 22, 2014
    #2
    Interesting. I once had a problem where my MBP wouldn't go to sleep, even when I closed the lid. Found out that it was because I left internet sharing on from when I had an iphone and connected the DAG4 to the internet. Internet sharing prevents your machine from sleeping because it needs to share internet. Turned it off and problem solved.
     

Share This Page