Screen sleep shortcut now broke

Discussion in 'macOS Sierra (10.12)' started by biglipps66, Aug 4, 2016.

  1. biglipps66 macrumors member

    Joined:
    Mar 11, 2012
    #1
    Agh. Shift-Control-Power to force screen off is now broke too. Jesus H.
    Beta, is killing me slowly
     
  2. Gameboy70 macrumors 6502

    Joined:
    Sep 21, 2011
    Location:
    Santa Monica, CA
    #2
    I never used the screen sleep feature on my MacBook, but I use the desktop equivalent on my iMac all the time: Shift-Control-Eject. As of yesterday, it stopped working, immediately after upgrading to Sierra.

    I also tried Shift-Control-Power on the MacBook. It doesn't work, either.
     
  3. Rok73 macrumors 65816

    Rok73

    Joined:
    Apr 21, 2015
    Location:
    Planet Earth
    #3
    Shift-Ctrl-Power still works on my MacBook Air with Sierra. Weird.
     
  4. Gameboy70, Sep 24, 2016
    Last edited: Sep 26, 2016

    Gameboy70 macrumors 6502

    Joined:
    Sep 21, 2011
    Location:
    Santa Monica, CA
    #4
    Shift-Control-Power works on my MacBook if I long press the power button for about a second. Maybe that's the way it always worked. I don't normally just put the screen to the sleep on the laptop, so I don't have a reference point for it's standard operation.

    On the iMac, I've noticed that it's not necessarily the screen sleep that's broken, but that the eject key isn't on my Wireless Apple Keyboard isn't being recognized. I need to do some more experimentation to figure out why.

    Update: I switched to an Apple wired keyboard today. The eject key works but Shift-Control-Eject still doesn't.

    Update 2: Karabiner (formerly KeyRemap4MacBook) was intercepting the eject key, even though no remappings for that key were enabled. The app is currently not compatible with Sierra. Uninstalling it restored the eject key functionality and the sleep shortcut.
     

Share This Page