Screen tearing while playing Portal *one*

Discussion in 'iMac' started by xkmxkmxlmx, May 5, 2011.

  1. xkmxkmxlmx macrumors 6502a

    xkmxkmxlmx

    Joined:
    Apr 28, 2011
    #1
    So I got my 2011 (3.1ghz, i5, 6970m1gb, 12GB RAM) this afternoon. After updating and getting it all setup, I decided to test out some games. I loaded up the first Portal through steam, as I have always owned it, but my old system would never let me get more than 15fps.

    It looks and sounds well enough, except for MASSIVE screen tearing. I mean, the entire screen up and down has about 10 lines at any given amount of movement.

    Anyone know why this would be?
     
  2. alust2013 macrumors 601

    alust2013

    Joined:
    Feb 6, 2010
    Location:
    On the fence
    #2
    I'd check res settings. Portal is reasonably old, so it may not like the resolution of the 27". I could be way off, but that's just a thought.
     
  3. dh2005 macrumors 6502a

    Joined:
    Jan 25, 2010
    #3
    Is there a V-Sync option in the System/Graphics menu of Portal? Sometimes called "Sync every frame"...

    ... make sure it's set to "yes". You have bucketloads of power, in that thing. Portal won't make it sweat. it's a setup issue.
     
  4. xkmxkmxlmx thread starter macrumors 6502a

    xkmxkmxlmx

    Joined:
    Apr 28, 2011
    #4
    Yup, that was it :) Something like "wait for sync". It was disabled by default on all Orange Box games.

    Thanks a lot :)
     
  5. treebark7182 macrumors member

    Joined:
    Mar 16, 2011
    #5
    ok I'm having the same issue and kind of new to steam.... I dont know where you're talking about to find that setting. I've looked all over. anyone mind walking me through a little?
     
  6. treebark7182 macrumors member

    Joined:
    Mar 16, 2011
    #6
    ok nevermind..... I found it.... I'm a little blind.... or dumb..... perhaps a tad drunk.........
     
  7. dh2005 macrumors 6502a

    Joined:
    Jan 25, 2010
    #7
    It should be in with the Graphics/Video settings. If you can't find it there, see whether there's an "Advanced" subsection.
     
  8. dh2005 macrumors 6502a

    Joined:
    Jan 25, 2010
    #8
    No worries, man. I've been there. :)
     
  9. tsugaru macrumors 6502

    Joined:
    Feb 9, 2003
    Location:
    Edmonton
    #9
    Doesn't explain the last two generations of 27" iMacs playing it fine.

    V-Sync or Double Buffering to Triple Buffering will most likely fix it.
     

Share This Page