Screen turns black randomly

Discussion in 'MacBook Pro' started by rolex54, Aug 20, 2007.

  1. rolex54 macrumors 6502

    Joined:
    Aug 20, 2007
    Location:
    Houston, TX
    #1
    recently my ibook g4 screen has been turning itself off randomly
    i have run tech tool pro which found no problems
    the screen will just go black at random intervals
    i attached it to a external monitor to check and as soon as the ibook screen went black the external display did also
    this computer is about 1.5 years old and is out of any type of warranty

    if anyone has had a similar problem please tell me what you had to do to fix it or if you were even able to fix it

    any tips or help would be great
     
  2. ScottDrummer macrumors 6502

    Joined:
    Jun 27, 2007
    Location:
    Canada
    #2
    do you have screen saver setup in one of your "corners" or as a hotkey?
     
  3. rolex54 thread starter macrumors 6502

    Joined:
    Aug 20, 2007
    Location:
    Houston, TX
    #3
    no there is no screen saver the screen will just suddenly turn black sometimes i can get it back by closing the display and putting it to sleep
    most of the time i have to hold the power button
    when i start it back up everything is fine until the same thing happends again
     
  4. jimbama macrumors newbie

    Joined:
    Oct 5, 2006
    #4
    This happened to me last night for the first time with my imac. Was using Google Earth and the screen just blacked out for no reason- computer seemed to be on in every other way but I couldn't get the screen back until I held down the power key to restart.

    A bit unsettling, to say the least....
     
  5. Gary King macrumors 6502

    Joined:
    Jun 14, 2004
  6. coastertux macrumors regular

    Joined:
    Jul 17, 2006
    #6
    This has been happening to me with my external monitor but not my MBP monitor...
     
  7. NIPRING macrumors 6502

    Joined:
    Jan 19, 2008
    Location:
    Waukesha WI
    #7
    Are you running Leopard? I installed leopard on my mini a few weeks ago, and i noticed this happens at least once a day. Sort of like its about to start the screen saver but a tap of any key brings it back. Mildly annoying is all :confused:.

    Bill
     
  8. Gary King macrumors 6502

    Joined:
    Jun 14, 2004
    #8
    Sounds like an Energy Saver setting for you, then. That's not the same as me. I can't bring it back once it's gone black.
     
  9. csteelekaplan macrumors newbie

    Joined:
    Apr 23, 2008
    #9
    Same thing

    I have an iMac G5 and this started happening to me about a month. I tried reinstalling all of the software and I thought it had solved the problem, but it has started to do it again.

    Same as with you, I will be working and all of the sudden the screen goes black. I can't get it to respond although you can hear the machine still running. I have to use the power button to get it to turn off and then back on again.

    Another thing that seems to be happening is that the screen will breakdown on the left hand side into a bunch of colors and then the other 75% will turn white. Again, I have to hold the power button down and then turn it back on.

    If anyone has the solution, please let us know!
     
  10. yarinb macrumors newbie

    Joined:
    Sep 5, 2007
    Location:
    Tel Aviv, Israel
    #10
    I have the exact same symptom.
    My new Penrym MBP screen will suddenly turn black. It happened for 3-4 times in the last week.
    My solution is to close/open the lid.

    something is bad with 10.5.2 and graphic card driver or something related to it. :mad:
     
  11. csteelekaplan macrumors newbie

    Joined:
    Apr 23, 2008
    #11
    Possible Solution

    Apparently this is a known issue with Apple and they have a program set up for us. Here's the link. My serial number falls a little out of their range but I am calling them anyways. Hope this helps everyone out.:D



    http://docs.info.apple.com/article.html?artnum=302181
     
  12. ucsdmac macrumors 6502

    ucsdmac

    Joined:
    Jan 28, 2008
    #12
    For your problem.. go to system pref >> displays >> uncheck the "automatically adjust brightness as ambient light changes.
     

Share This Page