Screen un-dims itself

Discussion in 'MacBook Pro' started by Taft123, Jul 3, 2011.

  1. Taft123 macrumors newbie

    Joined:
    Jul 3, 2011
    #1
    Hello,

    I have a 13" MacBook Pro that I bought in September of 2010, and I am now experiencing a problem with the monitor.

    When I dim the screen all the way down, it will stay black for a few moments but then it will come back on to the lowest setting. When I move the mouse, the screen goes back to black as if the computer didn't know the screen had come on again. I have to press the brightness button once to return it to the lowest setting.

    I have tried restarting my computer and all the updates are installed.

    Please advise.

    Thank you.
     
  2. Blondie :) macrumors 6502a

    Blondie :)

    Joined:
    May 12, 2010
    Location:
    Prescott, AZ
    #2
    I actually just figured this out for myself yesterday. The screen does indeed auto-dim itself. There is a sensor on the top of the monitor, right by where the iSight camera is located. This is also the location of the sensor that will turn your keyboard backlight on.

    Are you moving around in front of your computer when you notice the problem? That's when I noticed it for me.
     
  3. BCuz macrumors newbie

    Joined:
    Jul 16, 2011
    #3
    This is how I resolved this issue on my mac. Even manually dimming the screen in a perfectly dark room, with no change in ambient lighting, the screen still turned back on before I did this fix:

    After having the same screen problems, especially going to bed at night and waking up spooked that my screen randomly turned on, I started messing with the power settings and seem to have isolated the problem.

    If you go into your System Preferences under Energy Saver, uncheck the "Automatically Reduce Brightness Before Display Goes to Sleep" option. That immediately fixed the screen from coming back on.

    If other folks want to confirm whether that works across the board, that'd be helpful in self-diagnosing this problem without input from Apple.
     
  4. NZed macrumors 65816

    NZed

    Joined:
    Jan 24, 2011
    Location:
    Canada, Eh?
    #4
    To turn the Ambient Light Sensor off
    go to

    System Preference>Display>untick the box "Automatically adjust brightness as ambient light changes"
     

Share This Page