Screensaver comes on prematurely

Discussion in 'Mac Basics and Help' started by Texas_Toast, Jul 8, 2016.

  1. Texas_Toast macrumors 6502

    Texas_Toast

    Joined:
    Feb 6, 2016
    Location:
    Texas
    #1
    I just upgraded to El Capitan. Am finding quirky behavior here and there.

    Under System Preferences > Energy Saver for both Battery and Power Adapter, I have Computer Sleeps set to Never and Display sleeps at 20 minutes. Put hard disks to sleep when possible is not checked.

    Under Security & Privacy > General I have Require password immediately after sleep or screen saver begins.

    So why is it that I get locked out of my computer after maybe 5 minutes?

    I was talking on the phone last night - on my Mac - and I was constantly logging back in during the call, and I know this was happening every 5 minutes max.

    What is wrong?
     
  2. chabig macrumors 68040

    Joined:
    Sep 6, 2002
    #2
    Please post images of your Energy Saver preferences both Batter and Power Adapter?
     
  3. Texas_Toast thread starter macrumors 6502

    Texas_Toast

    Joined:
    Feb 6, 2016
    Location:
    Texas
    #3
    Well, I already described them, but here...

    energy_1.png


    energy_2.png
     
  4. chabig macrumors 68040

    Joined:
    Sep 6, 2002
    #4
    That's interesting, because they are different than mine. Your terminology threw me off because I don't have a slider for computer sleep. I have a MacBook Air 2013, btw.
    [​IMG]
    [​IMG]
    All I can think to recommend is to change your display sleep settings and save them. Then change them back.
     
  5. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #5
    The Screen Saver timeout is separate from Display Sleep.

    The Screen Saver timeout is under:
    System Preferences > Desktop & Screen Saver

    Make sure it's set to Never, or at least a value higher than your Display Sleep.
     
  6. Texas_Toast thread starter macrumors 6502

    Texas_Toast

    Joined:
    Feb 6, 2016
    Location:
    Texas
    #6
    That was it!

    Thanks!!! (I think I knew that, but obviously didn't remember!)
     

Share This Page