ScreenSaver Issue - iTunes Artwork comes up blank

Discussion in 'Mac OS X Lion (10.7)' started by Sylent Syd, Apr 1, 2012.

  1. Sylent Syd macrumors newbie

    Sylent Syd

    Joined:
    Apr 18, 2011
    Location:
    Kitchener, Ont
    #1
    Anyone else have this problem?...All other Screen Savers in the menu work fine, but iTunes Artwork doesn't show up, no matter what option I adjust it to.

    Worked fine in Snow Leopard - Any hints?
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    Even though some refer to an older version of iTunes, there are several proposed solutions in these threads that worked for some others. Hopefully, one will work for you:

    iTunes Artwork Screensaver no longer works after iTunes Match
    Album Art screensaver won't work...: Apple Support Communities
    itunes artwork screensaver not working: Apple Support Communities
     
  3. Sylent Syd thread starter macrumors newbie

    Sylent Syd

    Joined:
    Apr 18, 2011
    Location:
    Kitchener, Ont
    #3
    Much appreciated GGJStudios for all the information provided, but I could not find a scenario that solved my problem.

    I have a baseline early-2011 15"MBP, Lion, iTunes 10.6...also did not have an empty Music folder within my iTunes folder...and all my music is on the Macbook hard drive; not on an external...
     
  4. macleod199 macrumors 6502

    Joined:
    Mar 10, 2007
    #4
    Does it work some of the time, or never? I've always had sporadic problems with this, at least since 10.5 (on 10.7 now). It makes me wonder if it has to do with CPU/memory load or something.
     
  5. talino macrumors member

    Joined:
    Aug 16, 2010
    #5
    The screensaver didn't work at all until I removed Voice Memos (following Apple's own troubleshooting tip), then it worked fine for a couple of weeks, then it stopped working again, no idea why. I just get a black screen. Very annoying.
     
  6. Tesselator, Mar 2, 2013
    Last edited: Mar 2, 2013

    Tesselator macrumors 601

    Tesselator

    Joined:
    Jan 9, 2008
    Location:
    Japan
    #6
    My Album artwork "screen saver" works with all versions of iTunes in stand-alone, as a screen saver, and as an animated desktop background (wallpaper). And under all feasible system configurations.

    However my album art folder is "6,512,655,249 bytes (6.52 GB on disk) for 21,528 items" and can take a VERY VERY long time to load. While it's loading and resizing what it needs to the display is black as the OP describes. So maybe it's a similar problem?

    Additionally, I'm on a 8-core MacPro... if I were on a "baseline early-2011 15"MBP, Lion" it might take several times longer = which might be measured in hours. The good news is that it seems like the second time it's run it only takes a few tens of seconds (on my machine).

    <shrug>
     

Share This Page