Screnn brightness locked

Skerryman

macrumors newbie
Original poster
Nov 1, 2011
26
1
Had a quick search and couldn't find info, apologies if I missed anything. My screen brightness on my macbook is locked for some reason. Anytime I try to brighten the screen with the f5 or f6 keys the brightness thing pops up on screen but there's a symbol underneath indicating that its locked. Anyone know how I can sort this out its becoming a real pain in the a$$
 

Skerryman

macrumors newbie
Original poster
Nov 1, 2011
26
1
Yeah tried that. Used to happen the odd time but seems to be constant now.
 

Skerryman

macrumors newbie
Original poster
Nov 1, 2011
26
1
I'll try resetting the NVRAM and report back.

Don't have another keyboard to check if it still happens with external keyboard
 

GGJstudios

macrumors Westmere
May 16, 2008
44,427
786
Anytime I try to brighten the screen with the f5 or f6 keys
It's very late here and I completely missed this. The F5 and F6 keys are used to adjust the keyboard backlight brightness. F1 and F2 control the screen brightness.
 

Skerryman

macrumors newbie
Original poster
Nov 1, 2011
26
1
It's very late here and I completely missed this. The F5 and F6 keys are used to adjust the keyboard backlight brightness. F1 and F2 control the screen brightness.
Thanks for that. Now for my next question, does anyone know how to unlock my keyboard brightness keys? ;)
 

Skerryman

macrumors newbie
Original poster
Nov 1, 2011
26
1
I have the first unibody Macbook. Just checked it again there, it seems if I cover the light sensor it unlocks the brightness buttons but if its too bright it locks them up. News to me. Anyway thanks for all the help, apologies for the mixups, I blame it on the Friday factor.
 

wrldwzrd89

macrumors G5
Jun 6, 2003
12,107
75
Solon, OH
I have the first unibody Macbook. Just checked it again there, it seems if I cover the light sensor it unlocks the brightness buttons but if its too bright it locks them up. News to me. Anyway thanks for all the help, apologies for the mixups, I blame it on the Friday factor.
One more thing... check your System Preferences to see if setting keyboard / screen brightness automatically is available and enabled. If it is, turn it off.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.