Screwed up deleting old TM backups

Discussion in 'Mac OS X Lion (10.7)' started by TimeTravel, Jun 15, 2014.

  1. TimeTravel, Jun 15, 2014
    Last edited: Jun 15, 2014

    TimeTravel macrumors newbie

    Joined:
    Jun 15, 2014
    #1
    Hello,

    While backing up my files earlier on, I noticed it was taking an unusually high amount of time (50+ minutes, I was watching a movie) to do so. I checked which step it was getting stuck on, and figured out it was during the "cleaning old backups" part of the process.

    I decided to clean up the external drive I use for my backups myself, because I don't need all these old backups.

    I figured nothing could go wrong if I simply dragged the folders from Backups.backupdb to the trash, and then emptied it. I did just that, but while emptying, the numbers went into the negatives (items left to empty: -4000 for example). At this point I stopped the process.

    I looked around online for a solution, and found a couple of things. I tried the following:

    sudo rm -rf '/Volumes/Time Machine/.Trashes' Time Machine being my External Drive​

    It's still currently running, but it has began spewing out errors similar to the following :

    rm: .Trashes/501/2014-02-13-223137/Macintosh HD/Users/<My Drive>/Library/Application Support: Directory not empty​

    This leads me to a couple of questions:

    1) Is there a separate trash for my start up disk and my external drive?

    2) My external drive actually is partitioned into two, one of the two being for my TM backups, the other for some media files. Can I format the TM partition without it affecting the other?

    3) What can I do to fix the problem if not partition it?

    Additional details :

    - I'm using an intel SSD (not the stock one Apple offers)

    Thanks for any and all advice.

    Edit: Quick update. I let it run some more, and it seems to have finished.

    I'm not sure whether or not it worked, but when I check the bin the initial backup folders with the dates are still there. However it looks like the contents have drastically reduced, leaving only whatever was the cause of the errors I mentioned above. Does this mean it worked?

    Edit 2: Another update. I emptied the trash using the built-in option. Seems cleaned up. Backing up again to see if it is back to normal. 8 out of 57 GB. What have I done.
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    1) Yes. Each drive has its own hidden trash folder.

    2) Yes... you can use Disk Util to erase just the one partition.

    3) You should never manually mess around inside the TM backup file like you did and your backup is now very likely corrupted and I would not trust it.

    At this point I would erase the TM backup partition and start over and just let it run.
     
  3. TimeTravel thread starter macrumors newbie

    Joined:
    Jun 15, 2014

Share This Page