Screwed Up Permissions HELP

Discussion in 'macOS' started by kirky29, Aug 15, 2011.

  1. kirky29 macrumors 65816

    kirky29

    Joined:
    Jun 17, 2009
    Location:
    Lincolnshire, England
    #1
    Hi everybody,

    I've got some serious permissions issues.

    Ages ago I installed Snow Leopard on Partiton 1
    Then I installed Lion (Dev) on a new Partition 2
    I then copied by dragging most my files from partition 1 to Lion (on partition 2)
    Next I went back to Snow Leopard for awhile and dragged my main work folder back from Lion to SL
    Now I've moved back to Lion and again dragged my files from partition 1.

    Get it?

    But a lot of the files are screwed up, IE permissions. In the get info window there seems to be two " everybody " users and a " staff " user. On Snow Leopard & Lion I only have ONE user called " Kirk ".

    I've tried using the disk to repair permissions, I've tried using the dropbox option in the get info window. I've tried so much, but nothing is working?

    Now in apps like Photoshop it tells me it can't save because the file is locked or I don't have permission.
    And because of the new Versions thing in Pages / Preview, it tells me it can't save because, again, I don't have permission.

    Help me please :(!

    Attached is a picture of what the messed up permissions look like.
    Thank you!
     

    Attached Files:

  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    Odds are this is caused by an Access Control List on your user/home folder. Unlike regular UNIX permissions, ACLs can be inherited by subfolders... which would explain why you're having permission issues.

    Fortunately, this isn't too hard to fix. It does require a trip to UNIX-land (the Terminal), though. The chmod (change mode) command is useful for all sorts of permission changes. One of the things it can do is remove ACLs, with the -N option... which leads into the solution: First, find the offending folder with the ACL on it:
    1. Open Terminal
    2. Start at the folder that's giving you trouble: type cd, then a space, then drag and drop the folder icon on the Terminal window - this will paste its path
    3. Press Return to execute the command you just entered
    4. Now, type ls -la and press Return again - this will give you a long listing with ACL information.
    5. Type cd .. and press Return to go up one directory.
    6. Repeat the previous two steps until you find the offending folder - the output of the ls -la command will no longer have "everyone deny write" or something like that.
    7. Finally... type sudo chmod -N, then a space, then drag the offender to the Terminal window to paste its path as usual, and press Return to execute it.
    8. You will be prompted for your account password: Type it in. Note that you will not be able to see your typing - this is done for security reasons. Press Return when done.
    9. If it worked, the ACL will be gone, and your permission issues fixed.
     
  3. kirky29 thread starter macrumors 65816

    kirky29

    Joined:
    Jun 17, 2009
    Location:
    Lincolnshire, England
    #3
    Thanks for your reply (you were the only one decent enough to help!)

    But I found from a different website this:

    chmod -R -N ~

    -- I literally just typed that in, and it fixed everything.
    I've only got 3 names: Kirk (Me), staff & everyone.

    Kirk: Read & Write
    staff: Read only
    everyone: Read only

    - Everything is back to how it should be :)

    Thanks again!
     

Share This Page