Scrolling weirdness

Discussion in 'macOS' started by rnb2, Jan 30, 2011.

  1. rnb2 macrumors regular

    Joined:
    Jan 23, 2006
    Location:
    West Haven, CT, USA
    #1
    I have been having the following issue with my 2009 i7 iMac for the last few months. It is an irritant, but is gradually becoming maddening.

    Specifically, if the active window has a vertical scrollbar, it will start scrolling down automatically and won't stop until it reaches the 'bottom' of the window. You can pull the scrollbar back up from there, but it will immediately scroll down again. It doesn't happen all the time - it can occur from 1-2 times a day to once every couple of weeks, but once it gets triggered, only logging off or restarting will clear it. It has persisted over multiple revisions of 10.6.

    I am using a Wacom Intuos 3 tablet and a Magic Trackpad, and no mouse is active on the system. The scrolling issue occurs even if I unplug the Wacom tablet and turn off the Trackpad. There may also be some sort of x-mouse component - when the problem occurs, the Twitter for Mac window will become active if I pass the mouse cursor over it, but I don't think this applies to all windows. Also, the problem seems to occur more often in conjunction with iTunes (sometimes it will trigger right after I quit iTunes, for instance), for no reason that I can fathom.

    Anybody seen anything like this before? I'd do a fresh install and migrate my data, but am afraid that would just reimport whatever the problem file is - please let me know if this fear is unfounded.

    Thanks for any pointers or hints you can give me.
     
  2. r0k macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #2
    I remember having something like this on an old windows box with a sticky alt key. Every click would produce strange results. I could bang on the alt key to unstick it and get normal behavior again. You might try tapping the down arrow on your keyboard a few times the next time this happens just to make sure it isn't sticking. If it isn't a stuck key, an archive and install (not a fresh install) might just solve it for you.

    Sometimes you can spend hours flogging an elusive issue like this and then even more time on the phone with Apple support. Often an archive and install solves this sort of thing. Note that an archive and install involves booting from the OS X DVD, picking archive and install and walking away. When you return, you can log in and all your stuff is right where you left it. You have to sit through an OS X combo update to get you back from whatever DVD you had handy to today's OS X but overall this process is painless, can mostly run unattended and I have found it resolves pesky issues like the one you are having (if they are software related).
     
  3. rnb2 thread starter macrumors regular

    Joined:
    Jan 23, 2006
    Location:
    West Haven, CT, USA
    #3
    r0k - thanks! I went the archive and install route last night, though it really just acted like 'Install', since it was from the 10.6 disk that came with the iMac (no 'Archive and Install' option). It didn't even leave a "Previous System" folder when it was done, but it did need a couple passes through Software Update after the process finished.

    Haven't had a recurrence of the scrolling issue, but it's only been a few hours, so who knows? Thanks for the detailed breakdown of what to expect from the process.

    Rick
     
  4. rnb2 thread starter macrumors regular

    Joined:
    Jan 23, 2006
    Location:
    West Haven, CT, USA
    #4
    Well, the reinstall seemed to take care of the issue, but it actually just went dormant for a few days - it magically reappeared yesterday afternoon. It's only happened once so far, but it's clearly not fixed.

    Any other things I can check? It's definitely not a stuck key on the keyboard, as it still happens even if I turn off my Bluetooth keyboard when the auto-scrolling kicks in.
     
  5. donaldbyrd macrumors newbie

    Joined:
    May 30, 2011
    #5
    Scrolling Weirdness

    Anyone ever find a solution for this?
     

Share This Page