scrollview won't scroll

Discussion in 'iOS Programming' started by liptonlover, Oct 8, 2008.

  1. liptonlover macrumors 6502a

    Mar 13, 2008
    I have a scrollview with various views in it, each of those views has various objects in them... it's all properly parented/childed. I do simulate interface, and it all shows up, but I can't scroll! I'm testing with the iphone simulator, as I'm having trouble setting up my touch for testing. I also tried making the scrollview smaller than the stuff in it, right now they're the exact same size. But it still doesn't work. Any help would be appreciated.
    Thanks, Nate
  2. PhoneyDeveloper macrumors 68040


    Sep 2, 2008
    You have to set a UIScrollView's contentSize, in code, to the size of its contentView for it to scroll.
  3. chbeer macrumors member


    Sep 22, 2008
    I also struggled a long time with my control in a scrollview. The problem there seemed to be that the property "userInteractionEnabled" (or the like; can't remember) had to be set to YES.

Share This Page