SD Card is Read Only?

Discussion in 'Mac Accessories' started by chrisandersen, Mar 28, 2014.

  1. chrisandersen macrumors 6502

    chrisandersen

    Joined:
    Sep 6, 2008
    #1
    I purchased a new 32 GB SD card today and stuck into my laptop and cannot write to it. It says it is read-only. This is what disk util reports:
    2014-03-28 21:07:49 -0500:
    Name : APPLE SD Card Reader Media
    Type : Disk

    Partition Map Scheme : Master Boot Record
    Disk Identifier : disk2
    Media Name : APPLE SD Card Reader Media
    Media Type : Generic
    Connection Bus : USB
    USB Serial Number : 000000009833
    Device Tree : IODeviceTree:/PCI0@0/EHC2@6,1
    Writable : No
    Ejectable : Yes
    Location : Internal
    Total Capacity : 31.91 GB (31,914,983,424 Bytes)
    Disk Number : 2
    Partition Number : 0
    S.M.A.R.T. Status : Not Supported


    2014-03-28 21:09:13 -0500: Verifying volume “NO NAME”
    2014-03-28 21:09:13 -0500: Starting verification tool:
    2014-03-28 21:09:14 -0500: Checking file system
    2014-03-28 21:09:14 -0500: ** /dev/disk2s1

    2014-03-28 21:09:14 -0500: ** Phase 1 - Preparing FAT

    2014-03-28 21:09:14 -0500: ** Phase 2 - Checking Directories

    2014-03-28 21:09:14 -0500: ** Phase 3 - Checking for Orphan Clusters

    2014-03-28 21:09:14 -0500: 97 files, 31151424 KiB free (973482 clusters)

    2014-03-28 21:09:14 -0500: MARK FILE SYSTEM CLEAN? no

    2014-03-28 21:09:14 -0500:

    2014-03-28 21:09:14 -0500: ***** FILE SYSTEM IS LEFT MARKED AS DIRTY *****
     
  2. ggosson macrumors newbie

    Joined:
    Jul 6, 2010
    #2
    Obvious question, but is the little switch on the SD card in the LOCK position?
     
  3. chrisandersen thread starter macrumors 6502

    chrisandersen

    Joined:
    Sep 6, 2008
    #3
    it is in the un-locked position. Tried it the other way and it is the same.
     
  4. noodle654 macrumors 68020

    noodle654

    Joined:
    Jun 2, 2005
    Location:
    Never Ender
    #4
    I've had thus happen a few times. Sometimes dust can get in the SD slot so not all the pins make contact. Blow some canned air in there then try again. Sometimes you have to give it a little force. Also repair the card in Disk Utility.
     
  5. chrisandersen thread starter macrumors 6502

    chrisandersen

    Joined:
    Sep 6, 2008
    #5
    Tried the canned air trick with no luck. Took it to my iMac and it does report as read/write. Wrote a file to it successfully. Erased in disk util. It is setup as MSDOS FAT32. Took it back to MacBook Pro and it is the same, read-only.
    The problem is I need to take the laptop into the field and program some panels with the SD card.
    So, is it the laptop's card reader?

    ----------

    This is what the laptop reports in disk util
    Name : 32GB
    Type : Partition

    Disk Identifier : disk2s1
    Mount Point : /Volumes/32GB
    File System : MS-DOS (FAT32)
    Connection Bus : USB
    Device Tree : IODeviceTree:/PCI0@0/EHC2@6,1
    Writable : No
    Capacity : 31.91 GB (31,910,789,120 Bytes)
    Free Space : 31.9 GB (31,900,303,360 Bytes)
    Used : 2.7 MB (2,654,208 Bytes)
    Number of Files : 0
    Number of Folders : 0
    Owners Enabled : No
    Can Turn Owners Off : No
    Can Be Formatted : Yes
    Bootable : No
    Supports Journaling : No
    Journaled : No
    Disk Number : 2
    Partition Number : 1
     
  6. ColdCase macrumors 68030

    Joined:
    Feb 10, 2008
    Location:
    NH
    #6
    I've had issues with a few SD cards in my rMBP. Sometimes they work well after I restart the MBP. If you had the option to reformat the card to Mac OS, it may work better.

    Otherwise a USB type SD card reader is not that much money. For example, this one is $5

    http://www.newegg.com/Product/Product.aspx?Item=N82E16820283014
     
  7. MCAsan macrumors 601

    MCAsan

    Joined:
    Jul 9, 2012
    Location:
    Atlanta
    #7
    If you purchased the SD for use in a camera or other device, format it in that device. Always format CF or SD cards in the cameras. Then only read them in the laptop/desktop. Once read...back to the device for formatting and collecting the next set of images.

    For use moving data between computers, you might want to use an USB stick. Most computers will have a USB 2 or USB 3 port and not need any external reader.
     
  8. chrisandersen thread starter macrumors 6502

    chrisandersen

    Joined:
    Sep 6, 2008
    #8
    This is a special application where I must put some text in a .txt file and then move it to an alarm panel to insert the text onto the LCD screen of the alarm. They want it to be in windows, so the MS-DOS is probably correct. I went ahead and ordered a cheap USB2 dongle thingy.
     
  9. g4cube macrumors 6502a

    Joined:
    Apr 22, 2003
    #9
    COuld be that the laptop is older and does not support higher capacity SD card.

    What type of SD card? SDHC or SDXC?
    What model laptop?

    The fact that the card works fine in your iMac leads me to suspect you have an older laptop that does not support the newer SD card format.

    You may be able to use the card with an external USB card reader that will accept the SD card and provide a USB interface to the card.
     
  10. jperez36 macrumors newbie

    jperez36

    Joined:
    Apr 1, 2016
    #10

    reformat the sd card in your camera after youve saved your pics. its a magic fix, worked for me.
     
  11. es5694 macrumors member

    es5694

    Joined:
    Mar 31, 2016
    Location:
    Las Vegas
    #11
    Formatting the card fixes the card most of the times in such cases.
     
  12. SteveDavidson macrumors newbie

    Joined:
    Apr 30, 2016
    #12
    Even simpler: Move the lock/unlock slider to the middle position and try again. There's a flaky sensor that needs "special handling" and the midpoint seems to do the trick.
     

Share This Page