SD Card Issues

Discussion in 'OS X Yosemite (10.10)' started by coolburn, Jul 22, 2014.

  1. coolburn macrumors newbie

    Joined:
    Jul 22, 2014
    #1
    Since upgrading to Yosemite I have been having issues with the SD card reader. It won't recognize any of my cards. Has anybody else had this issue? Anybody know of a solution?
     
  2. arteggio macrumors member

    Joined:
    Dec 15, 2010
    Location:
    Pittsburgh
    #2
    Does it still show up in System Profiler? I'm not sure how to diagnose that. I just started using an SD cars heavily, beginning in DP3 into DP4 without a problem.
     
  3. Porsupah macrumors member

    Porsupah

    Joined:
    Oct 18, 2013
    Location:
    Probably near London or San Francisco
    #3
    Afraid not. You're referring to an internal reader, I assume? The one on my late 2013 15" rMBP's been fine throughout the betas - nothing unusual at all, with a 32GB SanDisk 95MB/s.
     
  4. dwfaust macrumors 68040

    dwfaust

    Joined:
    Jul 3, 2011
    Location:
    I am here => [•]
    #4
    No problems here. I have the StorEdge cards and a couple from Nifty plus the stock SanDisk. I am having no problems reading or writing from/to the cards in Yosemite DP4.
     
  5. wwp macrumors newbie

    Joined:
    Aug 31, 2014
    #5
    I'm having the same problem, on Yosemite public beta 2. It worked in public beta 1, and in mavericks before I upgraded.

    Here's a screenshot:

    [​IMG]

    It looks like it is not mounted, and when I click Mount, it gives the error message "Mount failed: The disk “NO NAME” could not be mounted.

    Try running First Aid on the disk and then retry mounting."
     
  6. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #6
  7. joedec macrumors 6502

    joedec

    Joined:
    Jul 25, 2014
    Location:
    Cupertino
    #7
  8. jrcsh6 macrumors 6502

    jrcsh6

    Joined:
    Jul 1, 2008
    #8
    I can get a card mounted but I cannot move anything to trash or format. I went ahead and reformatted on my camera but still cannot do anything with it. I hope/assume it's just a beta issue? I don't think it's the cards on iMac! Hoping!
     
  9. xuorced macrumors newbie

    Joined:
    Oct 24, 2014
    #9
    Same issue after upgrading to Yosemite

    I got exactly the same issue: my sd card (FAT32) is not mounted. The disk utility can see it, but nothing else.

    I try to format the sd card in a mac os format: no problem, the card is correctly mounted. But of course not accepted by my Nikon...

    Any idea to solve this problem?
     
  10. nellsybells macrumors newbie

    Joined:
    Oct 26, 2014
    #10
    Help SD CARD and YOSEMITE troubles


    I am having exactly the same issue, have you managed to solve it??
     
  11. RD22 macrumors newbie

    Joined:
    Jun 12, 2012
    #11
    I had similar issues with both SD cards and USB sticks - very annoying!

    In both cases these devices showed up on my desktop,in disk utility and on the finder window, however when I clicked on them from the desktop, the finder window that subsequently opened wouldn't show any of the files.

    I found that if this happened, relaunching finder (cmd+alt+esc, selecting finder and clicking relaunch), then opening a new finder window, navigating to the device (be it USB stick or SD card) by clicking it from the sidebar and opening it this way seemed to work.

    Not sure if this is exactly the same issue/fix but it worked for me!
     
  12. xuorced macrumors newbie

    Joined:
    Oct 24, 2014
    #12
    The SD card is only visible in the disk utility. I cannot ser it on the desktop... I git the sane issue euth my e-reader (kobo)....
     
  13. jrcsh6 macrumors 6502

    jrcsh6

    Joined:
    Jul 1, 2008
  14. karayuschij macrumors newbie

    Joined:
    Nov 1, 2014
    #14
    Same problem here.
    I see the cards in disk utility but cannot mount it, only eject it.
    No way to solve…
    This + wifi problems just let me think that Apple fools us more and more every day… :(
     
  15. blakek macrumors member

    Joined:
    Apr 26, 2013
    #15
    this is so annoying

    worked fine on the beta's early on

    now i can't use my $120 memory card, on my 2014 Air, but can on my 2013 iMac that I don't even need it for

    anything else that I can try here?
     
  16. Ray2 macrumors 6502a

    Joined:
    Jul 8, 2014
    #16
    Its just like usb3 drives. Just keep reinserting until it finally shows up. I have the issue, the above works for me.

    I've gotten to the point of not expecting I/O to work on newer Mac's and 10.9/10. Not happy about it but its pretty obvious the folks at Apple don't give a hoot. I/O is the main reason I stopped buying new Mac's. Decided to upgrade my old ones instead. Though with Yosemite I now have FireWire drives that won't spin down. My wife's 2014 Air is plagued with one I/O issue after another.
     
  17. blakek macrumors member

    Joined:
    Apr 26, 2013
    #17
    have you seen anywhere if the NiftyDrive thing works any better?
     
  18. signofthetimes macrumors newbie

    Joined:
    Dec 19, 2014
    Location:
    connecticut
    #18
    I just upgraded (Dec 2014) and my early-2011 MacBook Pro will no longer read my SD card. I use my camera constantly. This is a huge wrench in the works. Has Apple posted a fix?
     
  19. karayuschij macrumors newbie

    Joined:
    Nov 1, 2014
    #19
    I have solved restoring Mavericks :( (Bye bye Yosemite)
     
  20. kristoffer4 macrumors 6502a

    kristoffer4

    Joined:
    Jan 17, 2006
    Location:
    Denmark
  21. Eddn macrumors newbie

    Joined:
    Jan 1, 2015
    #21
    Fix

    I downloaded updated driver installer
    Rebooted now my card reader works perfectly
    OSX 10.10.1 MBP MID 2012

    http://www.acs.com.hk/en/driver/4/acr38-smart-card-reader/

    I used 17 Dec.2014

    Before utilities see the card would not mount or eject now all is working well
    Hope this helps .
     
  22. Dark Goob macrumors regular

    Dark Goob

    Joined:
    Jun 6, 2007
    Location:
    Portland, OR
    #22
    I am on 10.10.2 and cannot get SDHC cards to download to our 2008 iMac. It always freezes partway through copying and shows "disk i/o error" messages in the console along with a bunch of other stuff. Card and reader works perfectly on my 2012 MacBook Pro.

    Personally I think the JMicronATA driver is old and doesn't work right. Someone at Apple screwed up. My driver shows as being from 2012, and it loads during when the card is to be used, then fails.

    Either way Yosemite is an absolute joke, ususable piece of trash that I wouldn't wish on my worst enemy. Ugly icon redesign, can't download photos off a simple USB card reader, rush slow, tries to do lots of bells and whistles with notifications and social media but JUST DOESN'T FREAKING WORK. Worst MacOS release of all time.
     
  23. Eddn macrumors newbie

    Joined:
    Jan 1, 2015
    #23
    SD card ?

    I've never seen iMac 2008 with card reader or jMicron controler ?
    iMac 2008 uses USB only

    Try upgrading the external card reader or newer version of card reader. That comes with Dec. 2014 or newer driver script
    Newer iMac have differnt controler you speak of and your MacBook pro 2012 card reader uses USB .to control card and USB ports
    My mid 2012 15" MacBook pro developed issues when I installed and updated the USB software lucky me all come back "card reader"- and USB now works perfect.
    Please do "controler reset"

    Like you I felt OSX 10.10 was HORRIABLE ! Memory leaks
    Never give up now I'm using
    OSX 10.10.2 fixed most mempry leaks
    Disable some setting security reasons
    Little snich helps Apple will send user data out .
    Change setting so font is clear and easy to read on older "LED" screens

    Memory no less than 8 gig OSX 10.10.2 takes 3.5 gig on boot 1gig less than
    10.10
    Normal usage will increase to 5.6 out to 6.7 this is for my machines
    Older machine with spindle drive and low memory a swap file is going to write to the HDD slowing things down . If using ssd increased writes some say is bad for solid state drives . Increase memory is needed .to stop the 2 second pause .
    Miles will vary .
    Update the USB software
    Reset "controler"
    Hope this helps you on your iMac 2008 .
     
  24. oldradio macrumors newbie

    Joined:
    Mar 12, 2015
    #24
    I downloaded updated driver installer
    Rebooted now my card reader works perfectly
    OSX 10.10.1 MBP MID 2012

    http://www.acs.com.hk/en/driver/4/ac...t-card-reader/

    This worked for me too. Many thanks. There are a lot of "solutions" out there to this ignored issue with Yosemite but this uniquely makes sense. Perhaps Apple would consider including this driver update in their next patch?
     
  25. Eddn macrumors newbie

    Joined:
    Jan 1, 2015
    #25
    SD card readers

    Good news the updated driver works for you .
    Over the years I've nly read severl post helped at times
    Not so many .so many rely on resting SNC and PRAM is usefull
    If reset in poorer order most never do is nice post it's under
    "Memory Leaks " 10.10 shows correct way to reset . Is rite on
    You may want to view the post
    Update to 10.10.2 did resolve some memory leaks this I seen on my
    MacBook po.
    At first install of 10.10 I went like what ? Now I'm finding Apple is improving

    Is nice to hear you fixed your problem .with the same link that resolved my issue .now others will in time resolve their flustrating times .
    Also Apple could adress this isue in some update ? 3 or 4 or never .
    The answer is solved ? Seems so .with the updated drive .
    The programers use newer hardware is the result ..
    Adding memory to 8 gig is needed for sure if all you do is light Internet and Email stops the 2 second delay of opening a prpgram .
    Apple may say 10.10 will install on 2 gig good luck for that!
    If you do heavy graphic or VMware take note you need no less than 16 gig

    OSX 10.10 is very memory intense .some say unused memory is a waste ?
    You will have one gig lesse used with update 2 .
    Things change over time old thinking needs updated "resets" never solve hardware issue like the card reader
    Milage will very .
     

Share This Page