SD card not mounting or seen in Disk Utility

Discussion in 'MacBook Pro' started by nwbusa, Aug 23, 2010.

  1. nwbusa macrumors regular

    Joined:
    Jul 29, 2010
    Location:
    BC, Canada
    #1
    Hoping for some help with this one... I have a mid-2009 13" MBP (2.26, 4 gigs, 1TB HDD, SL 10.6.4) and the SD card reader is not recognizing any of my SD cards (won't mount and also not seen in Disk Utility). The cards are recognized when using a USB adaptor, and also work fine in my wife's MBP SD card reader, so I know it's not the cards. System Profiler recognizes the internal card reader on my system.

    I've tried resetting the SMC and reformatting the cards but nothing has worked so far. Any help is appreciated!

    EDIT: The SD card reader isn't working under OSX or in Windows, btw.
     
  2. budman1961 macrumors regular

    Joined:
    Mar 9, 2010
    #2
    I have had the same thing in my mid-year MBP i7. It seems that I have to re-seat the card a couple of times for the card to be seen by the system....

    I dont know if it is the card, ill try a different brand, and see if the results are similar.:D
     
  3. nwbusa thread starter macrumors regular

    Joined:
    Jul 29, 2010
    Location:
    BC, Canada
    #3
    I've tried a couple of different brands of cards, it doesn't work with any of them. It used to work fine, it's just recently that I tried to use it and it wasn't working.
     
  4. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #4
    "I've tried resetting the SMC and reformatting the cards but nothing has worked so far. Any help is appreciated!
    EDIT: The SD card reader isn't working under OSX or in Windows, btw."

    My _guess_ is that perhaps there is a hardware problem with the card reader itself.

    Do you have AppleCare or are you "out of warranty"?

    Try this:
    1. Don't put a card in the reader yet
    2. Open Apple System Profiler
    3. Does it "show the presence" of the card reader? (should be under "USB")

    If it doesn't "show", could be something wrong, either hardware, or the OSX software that controls the hardware.

    If it DOES show up, try this next:
    1. Put a card into the reader
    2. Again open Apple System Profiler
    3. Does it show something a bit differently now? That is to say, does ASP indicate that there is media in the card reader (even if the card isn't mounted on the desktop)?

    Just some thoughts...
     
  5. nwbusa thread starter macrumors regular

    Joined:
    Jul 29, 2010
    Location:
    BC, Canada
    #5
    Thanks for the reply -- I do in fact have AppleCare, just trying to avoid taking it in unless it's the only option.

    I tried your suggestion, and ASP does recognize the card reader (see below), but nothing changes when an SD card is inserted.

    I'm puzzled!

    Copied from ASP:

    USB High-Speed Bus:

    Host Controller Location: Built-in USB
    Host Controller Driver: AppleUSBEHCI
    PCI Device ID: 0x0aa9
    PCI Revision ID: 0x00b1
    PCI Vendor ID: 0x10de
    Bus Number: 0x26

    Internal Memory Card Reader:

    Product ID: 0x8403
    Vendor ID: 0x05ac (Apple Inc.)
    Version: 98.33
    Serial Number: 000000009833
    Speed: Up to 480 Mb/sec
    Manufacturer: Apple
    Location ID: 0x26500000
    Current Available (mA): 500
    Current Required (mA): 500
     
  6. rockstarjoe macrumors 6502a

    rockstarjoe

    Joined:
    Jun 2, 2006
    Location:
    washington dc
    #6
    I've found on my 2010 13" that I have to push the card in extra hard before it is recognized. You've probably already tried that, though...
     
  7. DewGuy1999 macrumors 68040

    DewGuy1999

    Joined:
    Jan 25, 2009
    #7
    Try creating another user account to see if it works, if so, it's something wrong with your current account and not the hardware.
     
  8. nwbusa thread starter macrumors regular

    Joined:
    Jul 29, 2010
    Location:
    BC, Canada
    #8
    So, problem solved... sorta.

    I tried all of the suggestions offered (thanks!), nothing worked though. Reset the PRAM and SMC (again), no joy. Finally, I blew really hard into the slot and tried the card, and it mounted right away! So I'm thinking, must have been some dust in there or something... but then when I wiggle the card slightly, the card will unmount, so there is either still some particulate matter in the slot that needs to be cleaned out, or some type of intermittent connection internally. I am thinking the former is more likely, so I'll use some compressed air later and possible a little isopropyl alcohol with an acid brush to clean the contacts, and see what happens.

    Thanks again to all who replied with suggestions!
     
  9. DTBJackal macrumors newbie

    Joined:
    Oct 17, 2006
    #9
    That worked for me too! So you're right that the SD card is prone to collecting dust. It is wide of course.
     
  10. nilsi macrumors newbie

    Joined:
    May 17, 2014
    #10
    Woow, after trying a lot it actually helped to blow compressed air into the socket. thanks alot
     
  11. cacho509 macrumors newbie

    Joined:
    Aug 19, 2014
    #11
    I press the command key+ r and restarted it at the same time, it worked for me.
     
  12. garthm macrumors newbie

    Joined:
    Aug 20, 2014
    #12
    I'm also having the same problem. No luck trying any of the above solutions.:(
    Mid 2010 21.5 in. iMac. Latest version of Mavericks.
     
  13. zappnduster macrumors newbie

    Joined:
    Sep 8, 2014
    #13
    SOLVED SD Card MBP

    Hi there,

    the SD-card won't show up in finder / iPhoto etc. on my 15" MBP early 2011.

    Solution: while pushed in completely into the slot I slightly pushed the end of the sd-card upwards (so that the contacts inside the slot obviously are now able to touch the sd-card's contacts) --> it works!

    i recon the card is too "thin", so for permanent access i would try and support it with a credit-card from underneath.

    that is no permanent fix but better than nothing….

    hope someone comes up with a improved fix.
     
  14. Milo42 macrumors newbie

    Joined:
    Dec 28, 2010
  15. garrett-k macrumors newbie

    garrett-k

    Joined:
    Dec 17, 2015
    #15
    That seemed to also work for me. #NintendoEra
     
  16. Parispoam macrumors newbie

    Joined:
    May 22, 2016
    #16
    Wow. Thank you. I just got a Macbook Pro (2011). SD card didn't show up. I read through the threads and nothing was working for me until I tried what you posted. It worked immediately. What exactly does that do? Thank you!
     
  17. TexasTopModel macrumors newbie

    TexasTopModel

    Joined:
    Jul 22, 2016
    #17
    Yes, compressed air worked for me. SMH it's 2016, I can't believe I had to google to find this fix. Thanks.
     
  18. nclark86 macrumors newbie

    Joined:
    Sep 28, 2016
    #18
    I had the same problem. I tried blowing it out but no success. To 'solve it' I had to pull up on the card while it was in the slot. This put more pressure on the contacts inside the reader. If I let go it ejected, so I had to import all the photos off the card whist pulling it up (bending it slightly, though not permanently!). Not an ideal solution but at least I have the contents now.
     
  19. chrroessner macrumors newbie

    chrroessner

    Joined:
    Jul 4, 2017
    #19
    This solved it for me. Many thanks
     

Share This Page