SD Card Problems

Discussion in 'Mac Basics and Help' started by Tumbleweed666, Apr 15, 2009.

  1. Tumbleweed666 macrumors 68000

    Joined:
    Mar 20, 2009
    Location:
    Near London, UK.
    #1
    I am plugging a SD card reader into my iMac for the first time after moving from PC, to update a FAT formatted SD card (it drives a photo frame). The reader I am using is one of the small 'pen' type readers which works fine on a PC and the disk does come up and is visible on the desktop but that's about as far as it goes :-(

    Numerous problems, the most urgent being the iMac can't read or write to it;
    1) I cannot copy files to it, usually I get a permissions error even though info shows I have read/write access (and how can I NOT have access to a FAT directory?) If I copy multiple items it says insufficient privileges, if I copy one item it asks me for my username/password which it accepts and then does nothing.
    2) I can't read it sometimes either, (but other times I can).
    2) Sometimes a file copy just seems to do nothing at all.
    3) I can't eject it, OSX says its in use.
    4) Spotlight insists on indexing it and putting files on it. Possibly other processes as well- examples, File ._.Trashes, Folders .Trashes, .Spotlight-V100, .fseventsd. Some of these folders have other files in them.

    The card/reader combo works fine on several XP PC's and the photo frame.

    I can't stop spotlight indexing it because it starts when I insert it so by the time I've added it to the exclude list its too late (and if I remove it and replace it it seems to be a new disk as far as spotlight is concerned. BUt the main issue is simple read/write access.

    Any ideas?
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    What about reformatting it with Disk Utility (Applications > Utilities) with the MS-DOS Filesystem (FAT 32)?
     
  3. Tumbleweed666 thread starter macrumors 68000

    Joined:
    Mar 20, 2009
    Location:
    Near London, UK.
    #3
    Its already FAT formatted, but I tried anyway with a different SD card, that failed "could not unmount disk'

    I'm wondering if its the reader/writer I'm using? Its one of these type (Not that exact one but similar)
     
  4. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #4
    I know, but maybe formatting it with Mac OS X' Disk Utility might solve the problem

    About the error you get, I don't know. Maybe a www search would help.
     
  5. Tumbleweed666 thread starter macrumors 68000

    Joined:
    Mar 20, 2009
    Location:
    Near London, UK.
    #5
    Mystery solved, it was the reader not the card. Another very similar looking reader I had purchased on eBay luckily arrived this morning, and the exact same card works flawlessly in it as does another that also does not work in the original reader.

    The reader that doesn't work (it works fine on XP) is marked "150x extreme jump reader", the one that does work has no markings on it but if anyone else has the same problem I can point them at the (UK) ebay seller where I bought it for just £2 inc P&P.
     

Share This Page