SD card reader no longer recognised?

Discussion in 'Mac Basics and Help' started by ck91, Feb 14, 2010.

  1. ck91 macrumors newbie

    Joined:
    Feb 14, 2010
    #1
    Hi there,

    I recently bought an SD card and reader for my Macbook Pro. It was working fine for a good month or so but as I was copying something to the card today, an error message appeared which said something about not having the right privilege to copy the content over to the SD card. The SD card was unmounted (if that's the word you'd use) automatically. When I tried plugging it back in to try again, nothing happened. I've tried plugging it into my PC but it says the device I've plugged in is not recognisable. The SD card reader has a red light that goes on when you plug it in which doesn't switch on anymore.

    I've put the SD card itself into my TV as I was copying some video onto it. 15 minutes of the video has been copied and it's playable which to me suggests that the SD card itself is fine? Is there any way I can get it working again? I don't really understand what's happened.

    I appreciate any help anyone could give me. Thanks!
     
  2. GoCubsGo macrumors Nehalem

    GoCubsGo

    Joined:
    Feb 19, 2005
    #2
    I would take it back. I had a flash drive that behaved in a similar fashion and just wound up returning it as it actually worked in windows but not on my mac.
     

Share This Page