SD card reader not working >:(

Discussion in 'MacBook Pro' started by Dal3, Jun 21, 2011.

  1. Dal3 macrumors newbie

    Joined:
    Jun 21, 2011
    #1
    Hi, I'm new here i just wanted to see if anyone else had this problem. my sd card reader on my 2 month old macbook pro just randomly stopped working. it worked great til now. any advise would be greatly appreciated. I need my laptop for college so I can't really drop it off anywhere to get fixed any time soon. thanks in advance for the help!
     
  2. awer25 macrumors 65816

    awer25

    Joined:
    Apr 30, 2011
    #2
    Do you live near an Apple store? They may be able to fix it while you're in the store.
     
  3. CFoss macrumors 6502

    Joined:
    Feb 26, 2011
    #3
    Try using a different SD card, to confirm that it isn't the SD Reader. If it's still not working, return the MacBook to Apple, as it's a defect.
     
  4. awer25 macrumors 65816

    awer25

    Joined:
    Apr 30, 2011
    #4
    Also, if they don't have the same one you are bringing in don't settle for less - often they will give you an upgraded model.
     
  5. DWBurke811 macrumors 6502a

    Joined:
    Jun 10, 2011
    Location:
    Boca Raton, FL
    #5
    the sd reader crapped out on my 7,1 mbp. needed a new logic board, luckily i bought apple care as it happened around 14 months after i bought it. took around 4 days for them to fix it, works like new now. would have been $500 if it wasn't under warrantee.
     
  6. Dal3 thread starter macrumors newbie

    Joined:
    Jun 21, 2011
    #6
    wow thank you all for the quick replies. i love this laptop and it sucks something had to break on it already. the nearest apple store is about 45 min away and i have class and work everyday so i need to figure something out.
     
  7. awer25 macrumors 65816

    awer25

    Joined:
    Apr 30, 2011
    #7
    You can always have a friend record the class, or better yet live broadcast it so you can hear it while you wait at the store.
     
  8. Ted939 macrumors newbie

    Joined:
    Nov 12, 2007
    Location:
    San Diego, CA
    #8
    Blow it out!

    Blowing out the dust from the SD slot worked for me! Thanks for the suggestion!
     

Share This Page