SDK 4 Beta

Discussion in 'iOS Programming' started by Sui Jen, May 21, 2010.

  1. Sui Jen macrumors newbie

    Joined:
    Oct 14, 2009
    #1
    Hi,

    I am currently using SDK 3.1.2. I am thinking of upgrading it to SDK 4 Beta.
    However I am afraid that I cannot modify the application of SDK 3.1.2 in SDK 4 Beta. Can application of SDK 3.1.2 be compiled in SDK 4 Beta? Is there anything that I need to consider before upgrading to SDK 4 Beta?

    Thanks a lot!
     
  2. fishkorp macrumors 68020

    fishkorp

    Joined:
    Apr 10, 2006
    Location:
    Ellicott City, MD
    #2
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_0 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8A274b Safari/6531.22.7)

    Keep both installed. If you build using the beta you cannot submit updates, even if base/target SDK is 3.x.

    I keep current in /Developer and the beta in /Developer-Beta
     
  3. uaecasher macrumors 65816

    uaecasher

    Joined:
    Jan 29, 2009
    Location:
    Stillwater, OK
    #3
    That's the best way to go.
     

Share This Page